Formelverkürzung einer Kettenformel

Bild

Betrifft: Formelverkürzung einer Kettenformel
von: Timon Röver
Geschrieben am: 08.06.2015 16:40:52

Hallo zusammen,
ich habe folgende Datei erstellt:
https://www.herber.de/bbs/user/98080.xlsx
Es geht um die Formeln in den Zellen W18:W50. Letztlich ist es dabei genau die gleiche, nur dass das erste, zweite, dritte usw. "x" aus der Tabelle links daneben ausgelesen werden soll.
Ich hab in der Zelle X12 ein Dropdown-Menü, in dem man das jeweilige Arbeitsfeld angeben kann. Dadurch erscheinen dann automatisch in den Zellen W18:W50 die Verfahrensansweisungen (VA's), die für das jeweilige Arbeitsfeld von Bedeutung sind.
Das ganze funktioniert in dieser Testversion auch soweit ganz gut.
Problematisch wird es, wenn ich alles, was in Spalte W:X eingetragen ist, in eine andere Datei bringen möchte (Daraus soll ein Einarbeitungsplan entstehen) und die Formel sich trotzdem auf die Tabelle in dieser Datei beziehen soll. Dadurch wird die ohnehin schon sehr lange Kettenformel nochmal deutlich länger.
Excel gibt mit dadurch dann die Meldung "Der eingegebene Text ist zu lang. Reduzieren sie die Anzahl der verwendeten Buchstaben oder brechen Sie die Eingabe ab." aus.
Daher meine Frage: Geht das ganze auch eleganter und deutlich kürzer?
Schönen Gruß
Timon Röver

Bild

Betrifft: mit AGGREGAT() sowie INDEX() und VERGLEICH() ...
von: der neopa C
Geschrieben am: 08.06.2015 16:56:23
Hallo Timon,
... folgende Formel in W17 (ohne ! {}!)
=WENNFEHLER(INDEX(T:T;AGGREGAT(15;6;ZEILE(A$1:A$99)/(INDEX($1:$1;VERGLEICH(X$12;$2:$2;)):INDEX($99:$99;VERGLEICH(X$12;$2:$2;))="x");ZEILE(A1)));"")
nach unten kopieren
Gruß Werner
.. , - ...

Bild

Betrifft: AW: mit AGGREGAT() sowie INDEX() und VERGLEICH() ...
von: Timon Röver
Geschrieben am: 08.06.2015 19:47:41
Hallo Werner,
perfekt! Ich danke dir. Ich bin einfach begeistert von diesem Forum. Hier gibt es für alles eine Lösung.
Gruß Timon

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Bedingte Formatierung spinnt in Pivot-Tabelle"