Microsoft Excel

Herbers Excel/VBA-Archiv

Zwei Listen vergleichen

Betrifft: Zwei Listen vergleichen von: Daniel
Geschrieben am: 27.06.2008 10:37:16

Hallo Forumsteilnehmer!

Ich benötige eure Hilfe, bei der Lösung des folgenden Problems.

Ich habe zwei Listen in Spalte A und L.
Ich möchte nun prüfen, welche Inhalte in ListeA vorhanden sind, die nicht in ListeL
vorhanden sind, und diese in Spalte N schreiben.
Außerdem soll geprüft werden, ob es Inhalte in ListeL gibt, die in ListeA nicht vorhanden
sind. Das soll dann in Spalte O geschrieben werden.

Ich würde das gerne ber VBA machen, um in ein bestehendes Sortiermakro einzubauen.

Beste Grüße,
Daniel

  

Betrifft: AW: Zwei Listen vergleichen von: Hajo_Zi
Geschrieben am: 27.06.2008 10:43:24

Hallo Daniel,

soll nur eine Spalte je Tabelle verglichen werden?
Tabelle vergleichen

GrußformelHomepage


  

Betrifft: AW: Zwei Listen vergleichen von: Daniel
Geschrieben am: 27.06.2008 11:09:56

Hallo Hajo,

das mit den Farben ist gut.
Ich habe mir Makro2 angesehen. Jedoch ist der Vergleich immer nur Zeilenweise von Paaren.
Mein Vergleich soll jeweils die komplette Liste prüfen:

A B
Wert1 Wert2
Wert2 Wert1
wären also jeweils vorhanden.
Ist ein solches Makro in deiner Datei enthalten?


  

Betrifft: AW: Zwei Listen vergleichen von: Daniel
Geschrieben am: 27.06.2008 12:13:50

offen vergessen.


  

Betrifft: AW: Zwei Listen vergleichen von: Hajo_Zi
Geschrieben am: 27.06.2008 12:35:27

Hallo Daniel,

ich hätte eigentlich gesehen das es jedes Makro das macht. Es wird immer die komplette Liste verglichen.

Gruß Hajo


  

Betrifft: AW: Zwei Listen vergleichen von: Daniel
Geschrieben am: 27.06.2008 13:09:13

Hallo Hajo,

dann muss ich etwas beim anpassen des Makros falsch gemacht haben.
https://www.herber.de/bbs/user/53407.xls
Kannst du da kurz mal reinschauen.
So viel Frabe dürfte da nicht drin sein.


  

Betrifft: AW: Zwei Listen vergleichen von: Hajo_Zi
Geschrieben am: 27.06.2008 13:18:55

Hallo Daniel,

die farbliche Markierung ist korrekt. Ich habe es mal mit Formel geprüft.
HDAX_SBF

 ALMN
1  Spalte ASpalte B
2ACAC Ja
3ACAACA Ja
4ADPADP Ja
5ADSADS Ja
6ADVAFJaJa


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Hajo


  

Betrifft: AW: Zwei Listen vergleichen von: Daniel
Geschrieben am: 27.06.2008 13:21:44

Wie macht man das mit der Tabelle im Forum?

Aus meiner Sicht sind die grünen Markierungen bei Zeile8-16 alle falsch, da die Inhalte ja in Spalte L vorkommen. Zwar versetzt um eine Zeile, aber das macht nichts.


  

Betrifft: AW: Zwei Listen vergleichen von: Hajo_Zi
Geschrieben am: 27.06.2008 13:27:13

Hallo Daniel,

der Link zum Tool ist am Ende, kostet aber Geld. Ein Tool das kostenlos ist aber nicht so umfangreich http://c.excelhost.de/c_beverly/getfile.php?id=122
Es wirdd ein kompletter Vergleich gemacht, einschl Leerstellen hinter dem Eintrag. Ansonsten muss noch Trim drum
If Trim(Worksheets("HDAX_SBF").Cells(LoI, 1)) = Trim(Worksheets("HDAX_SBF").Cells(LoJ, 12) )Then

Gruß Hajo


  

Betrifft: AW: Zwei Listen vergleichen von: Daniel
Geschrieben am: 27.06.2008 13:31:31

Ah, verstehe.


  

Betrifft: AW: Zwei Listen vergleichen von: Tino
Geschrieben am: 27.06.2008 10:45:31

Hallo,
könnte es so von Dir gemeint sein?

 ABCDE
1Hallo  Hallovorhanden
2Hallo1  Hallo1vorhanden
3Hallo2  Hallo2vorhanden
4Hallo3  Hallo3vorhanden
5Hallo4  Hallo10nicht vorhanden
6Hallo5  Hallo5vorhanden
7Hallo6  Hallo6vorhanden
8Hallo7  Hallo12nicht vorhanden
9Hallo8  Hallo8vorhanden

Formeln der Tabelle
ZelleFormel
E1=WENN(ZÄHLENWENN($A$1:$A$9;D1)>0;"vorhanden";"nicht vorhanden")
E2=WENN(ZÄHLENWENN($A$1:$A$9;D2)>0;"vorhanden";"nicht vorhanden")
E3=WENN(ZÄHLENWENN($A$1:$A$9;D3)>0;"vorhanden";"nicht vorhanden")
E4=WENN(ZÄHLENWENN($A$1:$A$9;D4)>0;"vorhanden";"nicht vorhanden")
E5=WENN(ZÄHLENWENN($A$1:$A$9;D5)>0;"vorhanden";"nicht vorhanden")
E6=WENN(ZÄHLENWENN($A$1:$A$9;D6)>0;"vorhanden";"nicht vorhanden")
E7=WENN(ZÄHLENWENN($A$1:$A$9;D7)>0;"vorhanden";"nicht vorhanden")
E8=WENN(ZÄHLENWENN($A$1:$A$9;D8)>0;"vorhanden";"nicht vorhanden")
E9=WENN(ZÄHLENWENN($A$1:$A$9;D9)>0;"vorhanden";"nicht vorhanden")




Gruß Tino

www.VBA-Excel.de




  

Betrifft: mit Makro von: Tino
Geschrieben am: 27.06.2008 10:58:31

Hallo,
hier das gleiche mit Makro, wo am Schluss nur dass Ergebnis vorhanden ist

Sub PrüfeListe()
Dim Bereich As Range
Application.ScreenUpdating = False
Set Bereich = Range("E1", Cells(Rows.Count, 5).End(xlUp))
    Bereich.FormulaR1C1 = _
        "=IF(COUNTIF(R1C1:R9C1,RC[-1])>0,""vorhanden"",""nicht vorhanden"")"
    Bereich.Value = Bereich.Value
    Set Bereich = Nothing
Application.ScreenUpdating = True
End Sub




Gruß Tino

www.VBA-Excel.de




 

Beiträge aus den Excel-Beispielen zum Thema "Zwei Listen vergleichen"