Microsoft Excel

Herbers Excel/VBA-Archiv

Spalten vergleichen und ein Zeichen in neue Tabell

Betrifft: Spalten vergleichen und ein Zeichen in neue Tabell von: Angelika
Geschrieben am: 07.09.2004 15:13:38

Hallo Excel Freunde,

ich möchte folgendes in meiner Tabelle machen:
Tabelle 1 Spalte "A1" hier gebe ich einen Begriff ein ( z.B. GL3030A09/110)
jetzt gibt es eine Tabellenblatt 2 auf dem verschiedene Begriffe aufgelistet sind z.B. GL3030A09/110( in Spalte"A1").
Nun soll mir Excel wenn ich den Begriff eingebe in Tabelle 1 diese mit Tabelle 2
vergleichen und wenn vorhanden ein L in Tabelle 1 Spalte "B1" einsetzen,
sollte dieser Begriff nicht dabei sein, dann möchte ich in Tabelle 1 Spalte "C1" ein M haben. Ist das möglich ????

Leider habe ich im Archiv nichts gefunden. Vielleicht kann mir jemand helfen.
Vielen Dank im voraus

  


Betrifft: AW: Spalten vergleichen und ein Zeichen in neue Ta von: Wolf-Dieter
Geschrieben am: 07.09.2004 16:40:02

Hallo Angelika,

das kannst Du mit zwei Formeln erreichen (erklärt an Deinem Beispiel):

in Zelle B1: =WENN(ZÄHLENWENN(Tabelle2!A1:A7;A1)>=1;"L";"")
in Zelle C1: =WENN(ZÄHLENWENN(Tabelle2!A1:A7;A1)=0;"M";"")

Erklärung: Tabelle2!A1:A7 mußt Du ersetzen durch den Bereich, den Du in deiner 2.Tabelle hast. In B1 wird nun geprüft, ob es diesen Wert aus A1 schon gibt und dann ein L geschrieben. Gibt es ihn nicht, dann nichts. In C1 dann das Ganze umgekehrt, es wird ein M geschrieben.


  


Betrifft: AW: Ergänzung von: Wolf-Dieter
Geschrieben am: 07.09.2004 17:17:28

... wenn das M nicht unter C1 stehen soll, kannst Du es auch gleich in B1 mit erledigen, indem Du die leere Zeichenkette "" durch "M" ersetzt. Also =WENN(ZÄHLENWENN(Tabelle2!A1:A7;A1)>=1;"L";"M")
Dann wird entweder L oder M geschrieben.


  


Betrifft: AW: Dankeschön von: Angelika
Geschrieben am: 08.09.2004 07:44:12

Hallo,

ich probiers jetzt gleich mal aus.
Sollte es nicht klappen meld ich mich nochmal;ansonsten
herzlichen Dank für die schnelle Hilfe

Liebe Grüsse vom Bodensee
Angelika


  


Betrifft: bitte noch mal um Hilfe von: Angelika
Geschrieben am: 08.09.2004 09:25:04

Hallo Excel Freaks, und Wolf-Dieter,
deine Formel funktioniert. Nur möchte ich den Bereich in Tabelle 1 nicht
festlegen, sondern ich möchte unabhängig von Tabelle 2 - Daten eingeben.
z.B. in Tabelle eins gebe ich ein GF1115B35/117, und nun soll automatisch
in Tabelle 1 Spalte B ein L erscheinen wenn dieser Typ (GF1115B35/117)in
Tabelle 2 in Spalte A hinterlegt ist.
Vielleicht habe ich mich ein bisschen kompliziert ausgedrückt.
Bitte helft mir nochmal. Danke

Angelika


  


Betrifft: AW: bitte noch mal um Hilfe von: Wolf-Dieter
Geschrieben am: 08.09.2004 09:53:42

Hallo Angelika,

ohne Festlegen des Bereichs (i.g. Fall Tabelle2!A1:A7) geht es nicht. Denn woher soll Excel wissen, mit welchen Daten verglichen werden soll?
Wenn es um das Autoausfüllen der Formel gehen sollte, dann gebe ich zu, unexakt gewesen zu sein. Dann muß es heißen: Tabelle2!$A$1:$A$7.
Eine Alternative dazu wäre noch das Festlegen eines Namen für den Bereich in Tabelle2. Dazu den Bereich markieren, über Menü Einfügen - Namen -Festlegen dann einen Namen vergeben (zB. Artikelnr) und dann wäre die Formel =wenn(zählenwenn(Artikelnr>=1;"L";"M"). Das ist aber letztendlich auch nur eine andere Schreibweise.

Viel Glück
Wolf-Dieter


  


Betrifft: nur zur Info von: Angelika
Geschrieben am: 08.09.2004 10:21:07

Hallo Wolf-Dieter,

wollte mich noch einmal bedanken bei dir, ich habe jetzt
meine Tabelle hinbekommen, dank deiner Formel.

Jeden Tag begeistert mich das Herber Excel Forum mehr.

sonnige Grüsse vom Bodensee
Angelika


  


Betrifft: AW: nochmals danke von: Angelika
Geschrieben am: 08.09.2004 10:07:47

Hallo Wolf-Dieter,
danke nochmal für deine echt superschnelle antwort.
Gruss Angelika


 

Beiträge aus den Excel-Beispielen zum Thema "Spalten vergleichen und ein Zeichen in neue Tabell"