Microsoft Excel

Herbers Excel/VBA-Archiv

Zeichenfolge in Spalten vergleichen

Betrifft: Zeichenfolge in Spalten vergleichen von: Abdi
Geschrieben am: 07.09.2004 19:30:37

Hallo zusammen,

es gibt ja soviele Beiträge zu "Vergleichen" aber irgendwie immer nur das Falsche :-)

Ich habe eine ellenlange Tabelle. In Spalte B stehen irgendwelche Zeichenfolgen z.B. "Huulllahupp11g".
In Spalte C stehen irgendwelche anderen Zeichenfolgen. z.b. "uull".
Jetzt würde ich es gerne haben, wenn die Zeichenfolge in Spalte C in B vorkommt, das mir der Inhalt von A in die Zeile der zu suchenden Zeichenfolge von C geschrieben wird.
Ohhjee. habe ich es erklären können?

Beispiel: Es wird in Spalte B gesucht nach der Zeichenfolge "uull" das in C5 steht. Bei finden von "huul" in Spalte B (z.B. B18), soll Inhalt von A18 in D5 geschrieben werden.

Jetzt ist´s verständlicher! ODER

Die zu suchenden Zeichenfolgen stehen alle untereinander (aber durcheinander, d.h. Zeichenfolge in C5 muss nicht in B5 vorkommen) in Spalte B

Kann mir jemand da helfen??

Danke

  


Betrifft: AW: Zeichenfolge in Spalten vergleichen von: FP
Geschrieben am: 07.09.2004 19:47:54

Hi Abdi,

meinst Du das so?

Tabelle3
 ABCD
11Huulllahupp11guula22
222Knuula  
33Formula  
Formeln der Tabelle
D1 : {=INDEX(A:A;MIN(WENN(ISTZAHL(SUCHEN(C1;B$1:B$100));ZEILE($1:$100))))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


oder soll auch überprüft werden, ob der Begriff laut C1 überhaupt vorhanden ist?

Tabelle3
 ABCD
11Huulllahupp11guulmanicht gefunden
222Knuula  
33Formula  
Formeln der Tabelle
D1 : =WENN(ZÄHLENWENN(B:B;"*"&C1&"*")>0;INDEX(A:A;MIN(WENN(ISTZAHL(SUCHEN(C1;B$1:B$100));ZEILE($1:$100))));"nicht gefunden")
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



Servus aus dem Salzkammergut
Franz


  


Betrifft: Danke. Das müsste es sein. von: Abdi
Geschrieben am: 07.09.2004 20:09:37

Wauw...Danke.

Wer kommt auf solche Formeln bitte. :-).

Danke, aber das war´s glaub ich. Zumindest hat der Heimtest Funktioniert!!!


  


Betrifft: @ Franz Warum nicht Index -Vergleich mit "*" ? o.T von: Josef B
Geschrieben am: 07.09.2004 20:43:16

.


 

Beiträge aus den Excel-Beispielen zum Thema "Zeichenfolge in Spalten vergleichen "