WENN-Funktion in Schleife



Excel-Version: 2000
nach unten

Betrifft: WENN-Funktion in Schleife
von: Werner Hassold
Geschrieben am: 08.05.2002 - 07:23:16

Hi Leute,
ich möchte die WENN-Abfrage in eine Schleife einbinden um
damit mehrere ZelenWerte abzufragen.
Beispiel: Wenn der Wert in Zelle A1>0 dann erhöhe den Wert
in Zelle B1 um EINS, wenn der Wert in Zelle A2>0 dann erhöhe
den Wert in Zelle B1 wiederum um EINS usw.
Das Ganze sollte in einer Schleife ablaufen (A1:A12).
Kann mir jemand ein Beispiel geben?
Würde mich sehr darüber freuen.
Freundliche Grüße
Werner
nach oben   nach unten

Re: WENN-Funktion in Schleife
von: UDF
Geschrieben am: 08.05.2002 - 07:39:11

Hallo Werner,

wenn ich Dich richtig verstanden habe, dann dürfte...

B1=ZÄHLENWENN(A1:A12;">0")

da schon reichen, oder?

Gruss
Markus

nach oben   nach unten

Re: WENN-Funktion in Schleife
von: MRR
Geschrieben am: 08.05.2002 - 07:40:44

Erzeuge ein Modul mit folgendem Code:

HTH, Matthias
nach oben   nach unten

Re: WENN-Funktion in Schleife
von: Werner Hassold
Geschrieben am: 08.05.2002 - 08:05:17

Danke für die schnellen Antworten,
werde es mal ausprobieren.
Freundliche Grüße
Werner

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "WENN-Funktion in Schleife"