Microsoft Excel

Herbers Excel/VBA-Archiv

Und-Oder-Verknüpfung

Betrifft: Und-Oder-Verknüpfung von: Hans Mansen
Geschrieben am: 12.08.2004 08:42:59

Hallo,

ich möchte gern eine Wenn-funktion mit einer und / oder Bedingung belegen.

z.B. Wenn im Feld A1 eine 4 oder 5 steht in gleichzeitig im Feld B1 eine 99 dann schreibe in Feld C1 das Wort OK.

Für Hilfe bin ich sehr dankbar.

  


Betrifft: AW: Und-Oder-Verknüpfung von: Nike
Geschrieben am: 12.08.2004 08:46:14

Hi,

=wenn(und(oder(A1=4;A1=5);b1=99);c1="OK";c1="")
mal schaun ob's hinhaut ;-)

Bye

Nike


  


Betrifft: AW: fast nike ;) von: Nico
Geschrieben am: 12.08.2004 08:50:46

=WENN(UND(ODER(A1=4;A1=5);B1=99);"OK";"")

so funktionierts.
gruß
Nico


  


Betrifft: AW: fast ... von: Nike
Geschrieben am: 12.08.2004 09:24:09

Hi,
leider is bei solchen Funktionen das Ergebnis recht binaer,
entweder es geht, oder nicht ;-)
Aber fuer ohne ausprobieren, war's doch recht nah drann ;-)

Bye

Nike


  


Betrifft: AW: Und-Oder-Verknüpfung von: Jörg Gradert
Geschrieben am: 12.08.2004 08:54:28

Hallo Nike,
in Formeln lassen sich keine Zieladressen übergeben, darum

Formel in C1:

=wenn(und(oder(A1=4;A1=5);B1=99);"OK";"")

Gruss Jörg


  


Betrifft: AW: Und-Oder-Verknüpfung von: Nike
Geschrieben am: 12.08.2004 09:24:44

Hi,
auch nicht in UDF Funktionen? ;-)

Bye

Nike


  


Betrifft: :-) o.T. von: Jörg Gradert
Geschrieben am: 12.08.2004 09:35:33