SVERWEIS und Summe

Bild

Betrifft: SVERWEIS und Summe von: Thomas G
Geschrieben am: 30.03.2005 12:33:05

Hallo zusammen,

ich brauche eure Hilfe.
Meine Frage wurde bestimmt schon öffters gestellt, leider konnte ich nichts finden.

Im Tabellenblatt1 habe ich von A1 bis A50 Artikel stehen.
Neben diesen Zellen stehen mehrere Zahlen oder auch #NV.

Jetzt möchte ich in Tabelle2 mittels einem SVerweis einen Artikel suchen und mir die Summe der komlpletten Zeile anzeigen lassen, wie gesagt kann auch in einer Zeile ein oder mehrere #NV vorkommen.

Ich wär euch sehr dankbar wenn mir jemand bei der Formel hilft.

Danke für eure Mühe.

Mit freundlichen Grüßen

Thomas

Bild


Betrifft: AW: SVERWEIS und Summe von: Fritz
Geschrieben am: 30.03.2005 12:52:21

Hi Thomas,

Die #NV sind sicherlich die Ergebnisse eines SVERWEISES. Diese würden ich durch eine WENN-FUNKTION auf 0 setzen.

Um die Summe zu ermitteln trotz #NV, würde ich eine Hilfsspalte für die Summe(Mit der SUMME-Funktion) in der Ausgangstabelle definieren, auf die ich dann im SVERWEIS zurückgreife.


Fritz


Bild


Betrifft: AW: SVERWEIS und Summe von: Thomas G
Geschrieben am: 30.03.2005 13:03:25

Hallo Fritz,

erstmal danke für Deine Antwort.

Du hast recht ich kann im vorhandenen SVerweis alles so setzen das ich eine Null angezeigt bekomme.

Nur kann ich leider keine Hilfszeile mehr einfügen. Andere Sheets sind schon auf dieses Datenblatt verknüpft.
Ich denke mir mal, das es trotzdem per SVerweis eine Möglichkeit gibt, mir
die Summe einer Zeile anzeigen zu lassen.
Vieleicht gibt es ja noch eine andere Möglichkeit wie ein SVERWEIS.

MfG

Thomas


Bild


Betrifft: Summe ohne #NV von: heikoS
Geschrieben am: 30.03.2005 13:07:24

Hallo Thomas,

z.B. so:

{=SUMME(WENN(A2:A6=D6;WENN(NICHT(ISTNV(B2:B6));B2:B6)))}

Als Matrix-Formel, also mit STRG+Shift+Enter abschließen.

Die #NV kannst Du aber auch bei Deinen Zahlen wegkriegen, indem Du dort den sverweis() änderst: wenn(istnv(sverweis());"";sverweis)). Dann geht´s auch mit summewenn(). Bei größerem Volumen sicherlich die bessere Wahl.


Gruß Heiko


Bild


Betrifft: AW: Summe ohne #NV von: Thomas G
Geschrieben am: 30.03.2005 13:30:53

Hallo zusammen,

danke an alle für eure Antworten.

leider komme ich damit nicht zurecht.

Ich brauche die Summe einer Zeile mittels SVERWEIS.

Vergessen wir einfach mal das #NV

Mir wär schon geholfen wenn ich diese normale Formel bekommen könnte.
Ich habe mal ein Beispiel mit hoch geladen.

https://www.herber.de/bbs/user/20371.xls


Totzdem danke für eure Mühe.

Mfg

Thomas


Bild


Betrifft: AW: Summe ohne #NV von: heikoS
Geschrieben am: 30.03.2005 13:59:22

Hallo Thomas,

ich habe die Formel etwas verändert (Bezug auf Tabelle1, Summenbereich):

{=SUMME(WENN(Tabelle1!A2:A6=A1;WENN(NICHT(ISTNV(Tabelle1!B2:H6));Tabelle1!B2:H6)))}

Und wie gesagt, die Formel ist eine Matrix-Formel daher:
- geschweifte Klammern {} nicht mit eingeben
- Formel NICHT mit Enter, sondern mit STRG+SHIFT+ENTER abschließen.

Ohne #NV geht auch:

=SUMMENPRODUKT((Tabelle1!A1:A6=A1)*(Tabelle1!B1:H6))


Gruß Heiko


Bild


Betrifft: Danke für die Hilfe von: Thomas G
Geschrieben am: 30.03.2005 14:24:13

Danke an alle für die Hilfe.

Hallo Heiko danke für Deine Formeln.
Es ist genau das was ich brauche.


Mit freundlichen Grüßen

Thomas


Bild


Betrifft: Danke für die Rückmeldung oT von: heikoS
Geschrieben am: 30.03.2005 14:45:11




Bild


Betrifft: AW: SVERWEIS und Summe von: BigRudi
Geschrieben am: 30.03.2005 13:09:12

hi,
angenommen so ähnlich sieht deine tabelle aus (siehe anhang). ergänze in spalte "e" eine summenformel wie folgt (damit wird NV# ausgeschlossen): =SUMMEWENN(C6:E6;"<1E+307";C6:E6) ~f~

Im 2. Tabellenblatt schreibst du in Spalte h6 das schlüsselwort (z.B. Brot). In der zelle rechts daneben folgende Formel: ~f~ =SVERWEIS(H6;A6:E8;5;FALSCH)

das müsste sein
grüsse bigrudi


 Bild

Beiträge aus den Excel-Beispielen zum Thema "SVERWEIS und Summe"