Microsoft Excel

Herbers Excel/VBA-Archiv

Aufrunden/abrunden auf 0.05 cents

Betrifft: Aufrunden/abrunden auf 0.05 cents von: Adrian Meyer
Geschrieben am: 19.08.2004 12:27:38

Hallo

Ich hätte eine Frage zum automatischen auf-/abrunden von Summen auf 0.05 Cents. Mit Welcher Formel erkennt Excel automatisch wie es zu runden hat?
Bsp. 1.326 Euro = 1.35 Euro
Bsp. 1.324 Euro = 1.30 Euro
Wie krieg ich das hin damit Excel dann auch automatisch mit den neuen Zahlen, sprich gerundeten 1.35/1.30 weiterrechnet und nicht mit der ursprünglich eingegebenen Zahl?

Vielen Dank für Eure Antwort!

  


Betrifft: AW: Aufrunden/abrunden auf 0.05 cents von: Dieter Maj
Geschrieben am: 19.08.2004 12:31:02

Hallo Adrian
so, z.B.:
'=RUNDEN($B4/0,05;0)*0,05

Gruß Dieter


  


Betrifft: AW: Aufrunden/abrunden auf 0.05 cents von: Michael
Geschrieben am: 19.08.2004 12:34:04

=INT(E4*100)/100

versuchs mal damit ...

(hab' nicht ganz verstanden, wie Du geanu gerundet hast)


  


Betrifft: AW: Aufrunden/abrunden auf 0.05 cents von: EtoPHG
Geschrieben am: 19.08.2004 13:00:57

Hallo Adrian,

Folgende 5er Rundungs-Formel funktioniert immer (auch z.B. in Word)


GANZZAHL(ZahlZuRunden*20+0.5)/20

Gruss Hansueli