Microsoft Excel

Herbers Excel/VBA-Archiv

Suchkriterium mehrfach vorhanden

Betrifft: Suchkriterium mehrfach vorhanden von: Dirk L.
Geschrieben am: 17.09.2014 15:31:36

Hallo Profis,

ich brauche mal wieder eure Hilfe.
Wie bekomme ich es hin, dass in einer Tabelle alle Daten untereinander aufgelistet werden, die in einer anderen Tabelle, neben einem mehrfach vorkommenden Suchkriterium stehen?
Beispieltabelle liegt bei.

https://www.herber.de/bbs/user/92691.xlsx

Danke im Voraus.

Gruß
Dirk L.

  

Betrifft: AW: Suchkriterium mehrfach vorhanden von: yummi
Geschrieben am: 17.09.2014 16:59:29

Hallo dirk,

mal ein Beispiel mit vba https://www.herber.de/bbs/user/92692.xlsm

Gruß
yummi


  

Betrifft: AW: Suchkriterium mehrfach vorhanden von: Dirk L.
Geschrieben am: 20.09.2014 21:15:07

Hallo yummi,

zuerst einmal Danke für Deine Hilfe, aber leider funktioniert die Auflistung nicht ganz richtig. Mal erfolgt eine Auflistung nach Eingabe des Suchkriteriums und mal nicht. Oft muss das Suchkriterium zweimal eingegeben werden. Das zweite Problem ist, dass nicht alle Auflistungseinträge nach Eingabe eines neuen Suchkriteriums glöscht werden. Als drittes darf das Suchkriterium nicht in Spalte A mit aufgelistet werden (hatte ich vergessen mitzuteilen), da dort bereits in der Originaltabelle Daten stehen, die nicht gelöscht werden dürfen.

https://www.herber.de/bbs/user/92734.xlsm

Für weitere Hilfen wäre ich sehr dankbar.

Gruß
Dirk L.


  

Betrifft: zwei Formellösungen mit INDEX() .. von: neopa C (paneo)
Geschrieben am: 21.09.2014 15:05:32

Hallo Dirk,

... im allgemeinen Fall so, wobei die Formel B4 einfach weit genug (z.B. bis B25) nach unten zu kopieren ist:

AUsgabetabelle

 B
1CP
2 
3Stoff
4Kohlenstoff
5Silizium
6Mangan
7Phosphor
8Schwefel
9Aluminium
10Bor
11Chrom+Molybdän
12Niob+Titan
13 

Formeln der Tabelle
ZelleFormel
B4{=WENNFEHLER(INDEX(Matrix!B:B;KKLEINSTE(WENN(Matrix!A$1:A$999=B$1;ZEILE(A$1:A$999)); ZEILE(A1))); "")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Allerdings ist mir unklar, warum Du ein Deiner Tabelle Matrix, die Daten für PAS/MHZ zweimal gelistet hast. Wenn dies ein Irrtum sein sollte und Deine Daten dort immer zusammenstehend sollen würde anstelle der Matrixformel auch eine einfachere Formel möglich sein.

AUsgabetabelle

 B
1CP
2 
3Stoff
4Kohlenstoff
5Silizium
6Mangan
7Phosphor
8Schwefel
9Aluminium
10Bor
11Chrom+Molybdän
12Niob+Titan
13 

Formeln der Tabelle
ZelleFormel
B4=WENN(ZEILE(A1)>ZÄHLENWENN(Matrix!A:A;B$1); "";INDEX(Matrix!B:B;VERGLEICH(B$1;Matrix!A:A;)+ZEILE(A1)-1))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Werner
.. , - ...


  

Betrifft: AW: zwei Formellösungen mit INDEX() .. von: Dirk L.
Geschrieben am: 22.09.2014 07:55:54

Hallo Werner,

besten Dank für Deine Hilfe, klappt super. Ich wusste doch, man kann sich auf euch verlassen.

Gruß
Dirk


 

Beiträge aus den Excel-Beispielen zum Thema "Suchkriterium mehrfach vorhanden"