Microsoft Excel

Herbers Excel/VBA-Archiv

Tabellenblatt dynamisch ansprechen


Betrifft: Tabellenblatt dynamisch ansprechen von: Philipp
Geschrieben am: 16.10.2017 16:50:51

Hallo Leute,
leider fällt mir keine Lösung für mein PRoblem ein und wende mich hiermit an Euch.

Bisheriger Zelleninhalt:
=SVERWEIS(SVERWEIS(O4;B2:K27;10;FALSCH); 'L:\Fehlerkosten\Intern\2017\FE\[PCBA 2017.xlsx]10'!$A$4:$H$37;7;FALSCH)

Hier suche ich eine Möglichkeit die fette "10" gegen den Inhalt der Zelle "O3" auszutauschen.

Der Inhalt von "O3" ist der aktuelle Monat, der mit "=TEXT(MONAT(heute());"##")" generiert wird.

Entweder stehe ich auf dem Schlauch mit der indirekt() Funktion, oder es ist nicht so trivial wie ich meine.

Vielen Dank schonmal für Eure Hilfe.

gruß
Philipp

  

Betrifft: AW: Tabellenblatt dynamisch ansprechen von: Hajo_Zi
Geschrieben am: 16.10.2017 17:30:16

schreibe für 10 O3

nur wenige schauen auf Deinen Rechner und sehen die Datei.
Ich möchte gerne den Fehler im Original sehen.

Ich baue keine Datei nach. Die Zeit hat schon jemand investiert.

Ein Nachbau sieht meist anders aus als das Original. Darum sollte das Original verlinkt werden.

Wenn du an Stelle einer Demomappe deine Originalmappe hochladen willst, diese aber sensible Daten enthält, kannst du diese Daten anonymisieren bzw. pseudonymisieren.

GrußformelHomepage


Ich gebe keinen Dank für eine Rückmeldung, da ich durch solche Beiträge nicht meine Beitragszahl erhöhen muss.
Also ich schreibe keine Beiträge mit dem Betreff "Gerne u. Danke für die Rückmeldung. o.w.T."
Rückmeldung ist ja in der Heutigen Zeit nicht üblich und die wenigen die eine Rückmeldung geben, mögen mir das verzeihen, das kein Danke für eine Rückmeldung kommt.

Beiträge von Werner, Luc, robert und folgende lese ich nicht.


  

Betrifft: AW: so wie Du es darlegst ... von: ... neopa C
Geschrieben am: 16.10.2017 18:00:18

Hallo Phlipp,

... geht das standardmäßig nicht. Es würde mit Hilfe von INDIREKT() funktionieren, wenn Deine Quelldatei geöffnet geöffnet ist. In dem Fall gäbe es allerdings keinen Bezug auf den Verzeichnisort der Datei, wie in Deiner Formel dargestellt. Es gibt mit einer Add-Ins (z.B. morefunce) zwar die Möglichkeit das trotzdem zu ermöglichen, zuvor solltest Du allerdings prüfen, ob Dein Bezug wirklich Datei übergreifend notwendig ist. Da gäbe es evtl. verschiedene Möglichkeiten.

Gruß Werner
.. , - ...


  

Betrifft: AW: Tabellenblatt dynamisch ansprechen von: Philipp
Geschrieben am: 16.10.2017 18:00:41

Hi,
die 2 Dateien sind hier.

https://www.herber.de/bbs/user/116998.xlsx -- pcba 2017.xlsx
https://www.herber.de/bbs/user/116999.xlsx -- PCBA KPI & DM.xlsx

gruß
Philiopp


  

Betrifft: AW: mit einer kleinen Hilfstabelle ... von: ... neopa C
Geschrieben am: 16.10.2017 19:28:25

Hallo Philipp,

... kannst Du auf das Add-In einrichten. Dazu in Deiner Datei pcba 2017.xlsx folgende Hilfstabellenblatt einrichten:

HilfsDaten

 AB
1  
2Aktueller Monat [Zahl]:10
3Anzuzeigender Arbeitstag:16.10.2017
4OTD [anzuzeigender Tag]:71%
5Anzahl zu Spät [anzuzeigender Tag]:2
6  

Formeln der Tabelle
ZelleFormel
B2='[PCBA KPI & DM.xlsx]Daten'!$O$3
B3='[PCBA KPI & DM.xlsx]Daten'!$O$4
B4=SVERWEIS(B3;INDIREKT("'"&B2&"'!$A$4:$H$37"); 7;0)
B5=SVERWEIS(B3;INDIREKT("'"&B2&"'!$A$4:$H$37"); 6;0)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Nun kannst Du in PCBA KPI & DM.xlsx folgende Auswertung vornehmen:

Daten

 NO
2Aktueller Monat:Oktober
3Aktueller Monat [Zahl]:10
4Anzuzeigender Arbeitstag:16.10.2017
5OTD [anzuzeigender Tag]:71%
6Anzahl zu Spät [anzuzeigender Tag]:2
7OTD [aktueller Monat]:17%
8Rückstand [Anzahl]: 
9Rückstand [Line Items]: 

Formeln der Tabelle
ZelleFormel
O2=TEXT($K$12;"MMMM")
O3=TEXT(MONAT($K$12); "##")
O4=VERWEIS(9;1/(D1:D13<>""); K2:K29)
O5='[pcba 2017.xlsx]HilfsDaten'!$B$4
O6='[pcba 2017.xlsx]HilfsDaten'!$B$5
O7=SVERWEIS($O$2;'[pcba 2017.xlsx]Jahr'!$A$4:$H$15;7;FALSCH)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


Beiträge aus den Excel-Beispielen zum Thema "Tabellenblatt dynamisch ansprechen"