Microsoft Excel

Herbers Excel/VBA-Archiv

SVERWEIS und Datum

Betrifft: SVERWEIS und Datum von: Hans
Geschrieben am: 17.09.2014 15:54:23

Hallo liebe Forumsteilnehmer,

ich habe einen SVERWEIS, der auf ein Feld zugreift welches mit folgendem
Format versehen ist "MM/JJJJ". Die Übergabe liefert allerdings den fortlaufenden
Wert und kein Datum.
Wir kann ich dem SVERWEIS die Formatierung mitgeben.
Habe es mit Text versucht ging aber nicht.

VG Hans

  

Betrifft: AW: SVERWEIS und Datum von: Daniel
Geschrieben am: 17.09.2014 16:00:00

Hi
geht nicht.
Formeln verwenden immer auf den unformatierten Zellwert.
Gruß Daniel


  

Betrifft: AW: SVERWEIS und Datum von: Hans
Geschrieben am: 17.09.2014 16:07:32

Hi Daniel,

ok Danke dir.

VG Hans


  

Betrifft: AW: SVERWEIS und Datum von: Rudi Maintaire
Geschrieben am: 17.09.2014 16:10:56

Hallo,
wenn in deiner Quelltabelle Text in der Form MM/JJJJ steht, geht das mit der Funktion Text().

ABCDEF
1MonatWert  MonatWert
207/20141  25.09.20142
309/20142    
410/20133    

ZelleFormel
F2=SVERWEIS(TEXT(E2;"MM/JJJJ");A1:B4;2;)


Gruß
Rudi


  

Betrifft: AW: SVERWEIS und Datum von: Hans
Geschrieben am: 17.09.2014 16:25:31

Hallo Rudi,

danke für deinen Hinweiß der hilft mir sicher an einer anderen Stelle noch.

In meinem Fall ist das Suchkriterium eindeutig eine Zahl. Der Rückgabewert
ist allerdings eine Datumsfeld (MM/JJJJ) und der kommt als Zahl an und nicht als
Datum im Format MM/JJJJ.

VG Hans


  

Betrifft: beispiel? owT von: Rudi Maintaire
Geschrieben am: 17.09.2014 16:35:28




  

Betrifft: AW: SVERWEIS und Datum von: Hans
Geschrieben am: 17.09.2014 16:41:09

Tabelle1

 ABCDEF
11005000Aug 14   
21015100Sep 14 10141883 5100
31025200Okt 14   
41035300Nov 14   

Formeln der Tabelle
ZelleFormel
F2=SVERWEIS(E2;A1:C3;3;0)&" "&SVERWEIS(E2;A1:C4;2;0)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8


  

Betrifft: AW: SVERWEIS und Datum von: Hans
Geschrieben am: 17.09.2014 16:41:21

Tabelle1

 ABCDEF
11005000Aug 14   
21015100Sep 14 10141883 5100
31025200Okt 14   
41035300Nov 14   

Formeln der Tabelle
ZelleFormel
F2=SVERWEIS(E2;A1:C3;3;0)&" "&SVERWEIS(E2;A1:C4;2;0)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8


  

Betrifft: das sieht so aus, ... von: Rudi Maintaire
Geschrieben am: 17.09.2014 16:52:57

Hallo,
...als ob dir
=Text(SVERWEIS(E2;A1:C3;3;0);"MMM JJJJ")&" "&SVERWEIS(E2;A1:C4;2;0)
weiterhilft.

Gruß
Rudi


 

Beiträge aus den Excel-Beispielen zum Thema "SVERWEIS und Datum"