Suche eine Formel für Sonderzahlen

Bild

Betrifft: Suche eine Formel für Sonderzahlen von: Werner
Geschrieben am: 28.03.2005 23:16:09

Hallo zusammen. Ich suche eine Formel die zum beispiel aus Windings 2 Zahlen adiert und zwar im Bereich B10:K10
8 mit Kreis + 1 mit Kreis + 2 mit Kreis + 9 + 7 Total 27
Also es kommen auch normale Zahlen ins Spiel. Ist das auch möglich wenn hinter der Zahl ein Punkt ist ? zum beispiel 1. + 2. + 4. Total 7

Die Formal sieht bei einer sonderzahl ja so aus =WENN(ISTTEXT(B10);8;(K10)
aber wie sieht es aus wenn mehrere sonderzahlen in dieser Reihe stehen ???

Gruss und Danke im voraus

Werner

Bild


Betrifft: AW: Suche eine Formel für Sonderzahlen von: Josef Ehrensberger
Geschrieben am: 28.03.2005 23:36:19

Hallo Werner!

Meinst du so?
Tabelle1
 ABCDEFGHIJKLM
9             
10 2.mk57.jq4r4.46 
11 2425718494 Zeile ausblenden!
12             
Formeln der Tabelle
L10 : =SUMME(B11:K11)
B11 : =WENN(CODE(B10)>57;WERT(ZEICHEN(CODE(B10)-57));WERT(ZEICHEN(CODE(B10))))
C11 : =WENN(CODE(C10)>57;WERT(ZEICHEN(CODE(C10)-57));WERT(ZEICHEN(CODE(C10))))
D11 : =WENN(CODE(D10)>57;WERT(ZEICHEN(CODE(D10)-57));WERT(ZEICHEN(CODE(D10))))
E11 : =WENN(CODE(E10)>57;WERT(ZEICHEN(CODE(E10)-57));WERT(ZEICHEN(CODE(E10))))
F11 : =WENN(CODE(F10)>57;WERT(ZEICHEN(CODE(F10)-57));WERT(ZEICHEN(CODE(F10))))
G11 : =WENN(CODE(G10)>57;WERT(ZEICHEN(CODE(G10)-57));WERT(ZEICHEN(CODE(G10))))
H11 : =WENN(CODE(H10)>57;WERT(ZEICHEN(CODE(H10)-57));WERT(ZEICHEN(CODE(H10))))
I11 : =WENN(CODE(I10)>57;WERT(ZEICHEN(CODE(I10)-57));WERT(ZEICHEN(CODE(I10))))
J11 : =WENN(CODE(J10)>57;WERT(ZEICHEN(CODE(J10)-57));WERT(ZEICHEN(CODE(J10))))
K11 : =WENN(CODE(K10)>57;WERT(ZEICHEN(CODE(K10)-57));WERT(ZEICHEN(CODE(K10))))
 



Die Schriftart "Wingdings 2" wird von der Jeanie leider nicht dargestellt!



Gruß Sepp


P.S.: Rückmeldung nicht vergessen!




Bild


Betrifft: AW: Suche eine Formel für Sonderzahlen von: Werner
Geschrieben am: 29.03.2005 11:25:10

Hallo Sepp, ja genau so hatte ich das gemeint, tausend Dank für deine Mühe. Ich muss sagen das Forum ist einfach klasse, wenn man Hilfe braucht, bekommt man sie auch.

Gruss Werner

Ps. wo bekommt man nur all diese Formeln her, die kann doch kein Mensch alle kennen ???


Bild


Betrifft: AW: ohne Hilfszeile von: HermannZ
Geschrieben am: 29.03.2005 12:54:04

Hallo Sepp,

warum nicht ohne Hilfszeile;

TestNeu
 ABCDEFGHIJK
1412.mk57.jq4r4.46
Formeln der Tabelle
K141 : {=SUMME(WENN(CODE(A141:J141)>57;WERT(ZEICHEN(CODE(A141:J141)-57));WERT(ZEICHEN(CODE(A141:J141)))))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hermann


Bild


Betrifft: AW: ohne Hilfszeile von: Werner
Geschrieben am: 29.03.2005 13:05:02

Hallo Hermann, das ist ja noch besser, einfach klasse.

Gruss ans Forum und nochmals Danke

Werner


Bild


Betrifft: AW: ohne Hilfszeile von: Werner
Geschrieben am: 29.03.2005 22:58:25

Hallo Hermann oder Sepp, das klappt ja wunderbar, bis auf ein Problem und zwar wenn nicht alle 10 Felder ausgefüllt sind, kommt die Fehlermeldung #Wert! Wenn ich eine Null eingebe ebenso, auch müsste ich ein X eingeben können, auch da die Fehlermeldung. Gibt es da noch eine möglichkeit ??? Ich denke schon nach der ersten Zahl sollte das ergebnis hinten stehen.

Gruss und besten Dank
Werner


Bild


Betrifft: AW: ohne Hilfszeile von: HermannZ
Geschrieben am: 30.03.2005 11:02:28

Hallo Werner,

hatte gerade festgestellt das du dich nochmal gemeldet hast.
zu deiner frage, selbstverständlich kann man das abfangen. ich habe jetzt das von dir
Beschriebene geändert,

Beispiel;

TestNeu
 ABCDEFGHIJK
140           
1412.mk57. q4rx41
142           
Formeln der Tabelle
K141 : {=SUMME(WENN(ISTFEHLER(WENN(CODE(A141:J141)>57;WERT(ZEICHEN(CODE(A141:J141)-57));WERT(ZEICHEN(CODE(A141:J141)))));0;WENN(CODE(A141:J141)>57;WERT(ZEICHEN(CODE(A141:J141)-57));WERT(ZEICHEN(CODE(A141:J141))))))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hermann


Bild


Betrifft: AW: ohne Hilfszeile von: Werner
Geschrieben am: 30.03.2005 11:15:12

Hallo Hermann, einfach Super!!!!

Tausend Dank für deine Hilfe

Werner


Bild


Betrifft: AW: Danke für die Rückantwort oT. von: HermannZ
Geschrieben am: 30.03.2005 11:27:42

.


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Suche eine Formel für Sonderzahlen"