Microsoft Excel

Herbers Excel/VBA-Archiv

Änderung von Zellbezügen in einer Formel | Herbers Excel-Forum


Betrifft: Änderung von Zellbezügen in einer Formel von: Christian Wendker
Geschrieben am: 18.01.2010 12:46:06

Liebe Forumexperten,
ich habe eine Formel, die ich durch horizontales ziehen des Ausfüllkästchens automatisch kopieren möchte. Die Formel lautet:
=wenn(Register1!B3="";wiederholen(Register1!C3;1);weiderholen(Register1!B3))
ich möchte jetzt das die nächste Formel so aussieht:
=wenn(Register1!B4="";wiederholen(Register1!C4;1);weiderholen(Register1!B4))
weiss jemand wie man das machen kann???

Vielen Dank schon mal im voraus
Christian

  

Betrifft: AW: Änderung von Zellbezügen in einer Formel von: Tino
Geschrieben am: 18.01.2010 12:58:23

Hallo,
so müsste es gehen.

=WENN(INDEX(Register1!$B:$B;SPALTE(C$1))="";WIEDERHOLEN(INDEX(Register1!$C:$C;SPALTE(C$1));1); weiderholen(INDEX(Register1!$B:$B;SPALTE(B$1)))) 
Die Funktion weiderholen kenne ich nicht.

Gruß Tino


  

Betrifft: ...Oder mit INDIREKT(ADRESSE(...)) und... von: Luc:-?
Geschrieben am: 18.01.2010 13:26:58

...vertauschen von Zeile und Spalte (Arg1/2) bei ADRESSE, Christian,
also so → ADRESSE(SPALTE(...);ZEILE(...)). Allerdings frage ich mich, was WIEDERHOLEN mit fest eingestellter Anzahl der Wiederholungen = 1 (Arg2) für einen (Un-)Sinn haben soll. Bei „weiderholen“ fehlt das Arg gleich ganz, also wenn optional, dann 0 → also Leerstring als Ergebnis. Deine Fml ist also suboptimal bis unsinnig...!
Gruß Luc :-?


  

Betrifft: AW: ...Oder mit INDIREKT(ADRESSE(...)) und... von: Christian Wendker
Geschrieben am: 20.01.2010 13:17:16

Danke hat mir sehr geholfen


Beiträge aus den Excel-Beispielen zum Thema "Änderung von Zellbezügen in einer Formel"