funktioniert als excel Formel ..wie aber als Makro

Bild

Betrifft: funktioniert als excel Formel ..wie aber als Makro
von: Martin H.
Geschrieben am: 16.11.2003 17:51:38

Ich habe folgende Formel:

Range("A8").Select
ActiveCell.FormulaR1C1 = _
"=+IF(AND(RC[9]=R[-1]C[9],RC[10]=R[-1]C[10]),R[-1]C+1,""1"")"
Range("A8").Select
Sheets("Werte-M+D").Select
Selection.AutoFill Destination:=Range("A8:A258"), Type:=xlFillDefault

Dabei entspricht:
"=+IF(AND(RC[9]=R[-1]C[9],RC[10]=R[-1]C[10]),R[-1]C+1,""1"")"
der Formel: =+WENN(UND(J8=J7;K8=K7);A7+1;"1")

Kann mir jemand die Syntax für =+WENN(AX8=0;"-"; schreiben?

Unten stehende Formel funktioniert. Nur ich brauche sie im Macro.

=+WENN(AX8=0;"-";WENN(UND(J8=J7;K8=K7);A7+1;"1"))

Danke

Bild


Betrifft: AW: funktioniert als excel Formel ..wie aber als Makro
von: Ramses
Geschrieben am: 16.11.2003 18:07:07

Hallo

verwende statt ".FormulaR1C1" die Option ".FormulaLocal" dann sollte es auch im Klartext gehen:

ActiveCell.FormulaLocal ="=+WENN(AX8=0;""-"";WENN(UND(J8=J7;K8=K7);A7+1;1))"

Die Anführungszeichen in einer Formel müssen immer doppelt sein

Gruss Rainer


Bild


Betrifft: Super, funktioniert
von: Martin H.
Geschrieben am: 16.11.2003 18:27:21

das hat auch den den Vorteil dass ich nun auch verstehe was die Formel im Makro aussagt.
Bei
"=+IF(AND(RC[9]=R[-1]C[9],RC[10]=R[-1]C[10]),R[-1]C+1,""1"")"
weis ich dass es funktioniert, weis auch wie er zählt, hätte es aber nie selber schreiben können.

Thanks


Bild

Beiträge aus den Excel-Beispielen zum Thema " funktioniert als excel Formel ..wie aber als Makro"