Microsoft Excel

Herbers Excel/VBA-Archiv

Min und max im Chart...

Betrifft: Min und max im Chart... von: Frank
Geschrieben am: 14.09.2004 18:32:18

Hallo Excelfreund,

ich möchte in einem yx-Punktdiagramm den Datenpunkt mit dem Minwert etwas größer
und grün formatiert haben. Der Maxwert sollte auch größer aber rot sein. Die
Marker sind Kreise, falls das eine Rolle spielt. Beide Punkte sollten mit min bzw. max beschriftet sein, alle anderen Punkte sollen keine Beschriftung haben.
Das Ganze ist ein Chart in einer Tabelle. Die Quelldaten sind im selben Blatt
und werden öfter am Tag aktualisiert. Der Vorgang müßte also automatisch erfolgen.

Ich bin da leider hoffnungslos überfordert.

Grüße und schon mal danke fürs Lesen.
Frank

PS. Es ist nur eine Datenreihe mit max. 31 Punkten.

  


Betrifft: AW: Min und max im Chart... von: Christoph M
Geschrieben am: 14.09.2004 19:33:54

Hallo Frank,
mein Vorschlag:
Berechne "MIN" und "MAX" in einem freien Bereich der Tabelle
Bsp
=MIN(A2:A32)
Hol dir die Zeilennummer dieser Min-Max-Werte
=VERGLEICH(MIN(A2:A32);A2:A32;0)
und erzeuge zwei neue Datenreihen (MIN und MAX)
mit den entsprechenden X- und Y-Bereichen.
Diese lassen sich natürlich unterschiedlich formatieren.
Gruß
Christoph


  


Betrifft: AW: Min und max im Chart... von: Frank
Geschrieben am: 14.09.2004 20:09:40

Hallo Christoph,

das geht so nicht, da nach jeder Aktualisierung der min und max ein anderer Datenpunkt sein kann und dementsprechend umformatiert werden muss.

Gruß Frank


  


Betrifft: AW: Min und max im Chart... von: K.Rola
Geschrieben am: 14.09.2004 20:13:17

Hallo,

lad mal eine vorbereitete Mappe hoch, dann bau ich dir das da ein.

Gruß K.Rola


  


Betrifft: AW: Min und max im Chart... von: Frank
Geschrieben am: 14.09.2004 21:09:04

Hallo K.Rola,

die Lösung von Christoph klappt.
Danke auch für deine Bereitschaft.

Gruß Frank


  


Betrifft: AW: Min und max im Chart... von: Christoph M
Geschrieben am: 14.09.2004 20:29:07

Hi Frank
geht schon. Es wird eben nicht ein Datenpunkt geändert, sondern neue Datenreihen hinzugenommen.
https://www.herber.de/bbs/user/10885.xls

Gruß
Christoph


  


Betrifft: AW: Min und max im Chart... von: Frank
Geschrieben am: 14.09.2004 21:07:44

Hallo Christoph,

danke, das klappt wie gewünscht.

Gruß Frank


  


Betrifft: Danke für die Rückmeldung (o.T.) von: Christoph M
Geschrieben am: 14.09.2004 22:03:17




  


Betrifft: AW: Min und max im Chart... von: K.Rola
Geschrieben am: 14.09.2004 20:53:11

Hallo,

die Lösung von Christoph sollte doch dein Problem lösen, oder?

Gruß K.Rola


  


Betrifft: Schade... von: Christoph M
Geschrieben am: 14.09.2004 22:10:01

...jetzt hab ich mir deine Lösung entgehen lassen...

Hi K.Rola
ich hatte mir auch mal 'ne VBA-Lösung gestrickt, mit der ich einzelne Datenpunkte markieren (und auch formatieren) konnte, hab diese aber irgendwie "verbaselt".
Auf deine Lösung wäre ich gespannt gewesen.

Gruß
Christoph


  


Betrifft: AW: Schade... von: K.Rola
Geschrieben am: 15.09.2004 00:38:09

Hallo,

einfach die Werte der SeriesCollection in ein Array einlesen, dann abklappern und wenn
der Wert = max des Arrays ist, den Punkt mit gleichem Index formatieren.

Gruß K.Rola