Microsoft Excel

Herbers Excel/VBA-Archiv

Matrix-Formel Probleme: Min/Max, Kombinationen, Mi

    Betrifft: Matrix-Formel Probleme: Min/Max, Kombinationen, Mi von: jan
    Geschrieben am: 30.08.2003 13:41:34

    Hallo,

    ich suche nach Formel-Lösungen (also kein VBA) zu folgenden Problemen. Wäre klasse, wenn jemand mir wieder Expertenwissen zukommen lassen würde. Folgend eine Matrix mit 3 Spalten (A bis C) und 6 Zeilen.

    2 c y
    2 a x
    3 a x
    2 a x
    4 b x
    3 b y


    I. Ich möchte den kleinsten Wert in Spalte A ausgegeben haben, wenn Spalte B = „a“ und Spalte C = „x“. Als 2tes möchte ich den größten Wert aus Spalte A ausgeben, auf den die 2 Bedingungen zutreffen.

    II. Ich möchte die 2er-Kombination aus Spalte B und C wissen, die am häufigsten vorkommt (hier also „a“ mit „x“) und wissen wie häufig sie vorkommt. Geht das auch mit 3 Spalten (hier wäre dann das Ergebnis 2 Mal Kombination „2 a x“)? Kann man auch jeweils die zweit-häufigsten, dritt-häufigsten etc. Kombinationen ausgeben lassen?

    III. Ich möchte den Mittelwert aus Spalte A ausgegeben haben, wenn Spalte B = „a“ und Spalte C = „x“. Gibt es eine elegantere Lösung als SUMMENPRODUKT((B1:B6=“a“)*(C1:C6=“x“)*A1:A6)/ SUMMENPRODUKT((B1:B6=“a“)*(C1:C6=“x“) ?

      


    Betrifft: AW: Matrix-Formel Probleme: Min/Max, Kombinationen, Mi von: th.heinrich
    Geschrieben am: 30.08.2003 14:08:21

    hallo Jan,

    zu 1) =WENN(UND(B1:B6="a";C1:C6="x");MIN($A$1:$A$6);"") als MATRIX-FORMEL eingeben STRG+SHIFT+ENTER. MAXIMUM entsprechend.

    zu 2) in arbeit.

    zu 3) glaube nicht.

    gruss thomas


      


    Betrifft: sorry 1) stimmt nicht ot. von: th.heinrich
    Geschrieben am: 30.08.2003 14:32:55

    .


      


    Betrifft: Danke Thomas! von: jan
    Geschrieben am: 30.08.2003 21:40:52

    Das mit den Kombinationen scheint aber recht schwierig, oder?


      


    Betrifft: AW: Danke Thomas! von: th.heinrich
    Geschrieben am: 30.08.2003 22:41:20

    hallo Jan,

    warum danke, bist durch mich nicht weitergekommen.

    vorschlag: starte einen neuen thread mit dem ansatz den Du hast, und packe nicht mehrere probs hinein.

    bin selbst weiter am testen.

    gruss thomas.


      


    Betrifft: AW: Matrix-Formel Probleme: Min/Max, Kombinationen, Mi von: andre
    Geschrieben am: 30.08.2003 18:49:19

    hallo jan,
    vielleicht hilft die diese site:
    http://www.excelformeln.de/formeln.html?welcher=74
    ansonsten hatte ich ein ähnliches problem mit vba gelöst.
    gruss andre


      


    Betrifft: AW: Matrix-Formel Probleme: Min/Max, Kombinationen, Mi von: Franz Pölt
    Geschrieben am: 31.08.2003 17:59:21

    Hallo Jan,

    Alle Formeleingaben mit STRG+UMSCHALT+EINGABE beenden!

    Minimum:
    =MIN(WENN(B1:B6&C1:C6="ax";A1:A6))
    Maximum:
    =MAX(WENN(B1:B6&C1:C6="ax";A1:A6))
    Wie oft kommt "ax":
    =SUMME((B1:B6="a")*(C1:C6="x"))
    Mittelwert wenn "ax":
    =MITTELWERT(WENN(B1:B6&C1:C6="ax";A1:A6))

    und jetzt kommt der Hammer!

    wie oft kommt die häufigste Kombination vor?
    =SUMME((MTRANS(ZEILE(B1:B6)^2+MAX(ZEILE(B1:B6))-ZEILE(B1:B6))=SUMME((B1:B6&C1:C6=MTRANS(B1:B6&C1:C6))*1))*MTRANS(ZEILE(B1:B6)))

    Bist du damit zufrieden?

    Servus aus dem Salzkammergut
    Franz


      


    Betrifft: AW: Matrix-Formeln - Nachtrag wieviele Kombis von: Franz Pölt
    Geschrieben am: 31.08.2003 18:11:10

    Hallo Jan,

    wieviele Kombinationen gibt es?
    =SUMME(((VERGLEICH(B1:B6&C1:C6;B1:B6&C1:C6;0))=ZEILE(B1:B6))*1)

    Servus aus dem Salzkammergut
    Franz


      


    Betrifft: AW: Matrix-Formel Probleme: Min/Max, Kombinationen, Mi von: Franz Pölt
    Geschrieben am: 31.08.2003 18:35:48

    Hallo Jan,

    Formel für wie oft kommt der häufigste Eintrag vor war falsch!

    Hier die richtigen Formeln:

    Welcher Eintrag kommt am häufigsten vor?
    =INDEX(MTRANS(B1:B6&C1:C6);MAX(((VERGLEICH(B1:B6&C1:C6;B1:B6&C1:C6;0))<>ZEILE(B1:B6))*ZEILE(B1:B6)))

    Wie oft kommt er vor?
    =SUMME((B1:B6&C1:C6=INDEX(MTRANS(B1:B6&C1:C6);MAX(((VERGLEICH(B1:B6&C1:C6;B1:B6&C1:C6;0))<>ZEILE(B1:B6))*ZEILE(B1:B6))))*1)

    Alle Formeln sind "Matrix" bzw. "Array"-Formeln (Eingabe mit STRG+UMSCHALT+EINGABE) beenden!

    Servus aus dem Salzkammergut
    Franz