Microsoft Excel

Herbers Excel/VBA-Archiv

Zählen wenn Wert größer ist als anderer Wert | Herbers Excel-Forum


Betrifft: Zählen wenn Wert größer ist als anderer Wert von: Simon
Geschrieben am: 15.12.2009 10:46:29

Hallo zusammen,

kurz die Beschreibung meines Problemes:

Ich habe in Spalte A 50 Werte. Ebenso habe ich auch in Spalte B 50 Werte.

Nun würde ich gerne mithilfe einer Funktion herausfinden wollen, wieviele Werte in A größer sind als der entsprechende Wert in B (also z.B. A1 und B1, A2 und B2, usw.)

Es geht schon wenn man mit einer Wenn-Funktion pro Wertepaar eine 1 oder ein 0 ausgeben lässt und nachher aufsummiert, aber da muss es auch eine elegantere Läsung geben, meines Erachtens.

Die Funtion "Zählenwenn" würde eigentlich dem am nächsten kommen, aber funktioniert auch nicht.

Hat jemand eine Idee?

Schöne Grüße,
Simon

  

Betrifft: =SUMMENPRODUKT(N(A1:A50>B1:B50)) von: {Boris}
Geschrieben am: 15.12.2009 10:50:18

Grüße Boris


  

Betrifft: AW: =SUMMENPRODUKT(N(A1:A50>B1:B50)) von: Simon
Geschrieben am: 15.12.2009 10:56:59

Hallo Boris,

das funktioniert auch nicht. Versteh auch das "N" in der Formel nicht.

Ich will auch keine Multiplikationen, sondern lediglich die Anzahl der Werte in B die größer sind als in A.


  

Betrifft: Klar funktioniert die Formel... von: Matthias5
Geschrieben am: 15.12.2009 11:59:19

Hallo Simon,

doch doch, die Formel funktioniert.
Allerdings schreibst du zuerst, dass du die Werte in A zählen willst, die größer sind als die entsprechenden Werte in B. Jetzt schreibst du es umgekehrt. Dann musst du halt die Bezüge in der Formel entsprechend umdrehen.
Zu beachten ist außerdem, dass eine Leerzelle als 0 gewertet wird. Sollen nur Zeilen berücksichtigt werden, in denen beide Zellen gefüllt sind, müsstest du die Formel erweitern:
=SUMMENPRODUKT((A1:A10>B1:B10)*(A1:A10<>"")*(B1:B10<>""))

Gruß,
Matthias


  

Betrifft: Das ist 1 zu 1... von: {Boris}
Geschrieben am: 15.12.2009 12:03:58

Hi Simon,

...die Antwort auf Deine Frage

Ich habe in Spalte A 50 Werte. Ebenso habe ich auch in Spalte B 50 Werte.

Nun würde ich gerne mithilfe einer Funktion herausfinden wollen, wieviele Werte in A größer sind als der entsprechende Wert in B


=SUMMENPRODUKT(N(A1:A50>B1:B50))

Grüße Boris


  

Betrifft: AW: Zählen wenn Wert größer ist als anderer Wert von: Tino
Geschrieben am: 15.12.2009 10:56:11

Hallo,
bin nicht der Formelspeziallist, geht es so?

 ABCD
111 Ergebnis
222 3
333  
444  
55   
66   
77   
82   

Formeln der Tabelle
ZelleFormel
D2{=ZÄHLENWENN(B1:B1000;">"&A1:A1000)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen



Gruß Tino


  

Betrifft: AW: Zählen wenn Wert größer ist als anderer Wert von: Simon
Geschrieben am: 15.12.2009 11:00:40

Hallo Tino,

das funktioniert, danke dir, auf die geschweiften Klammern wär ich nie gekommen.

Danke nochmals


  

Betrifft: Fällt Dir nix auf? von: {Boris}
Geschrieben am: 15.12.2009 11:39:02

Hi Tino,

wie kommt die Formel im Ergebnis denn auf 3? ;-))

Grüße Boris


  

Betrifft: stimmt von: Tino
Geschrieben am: 15.12.2009 12:12:26

Hallo,
stimmt das Beispiel war falsch aufgebaut sonst wäre es mir aufgefallen das sich Spalte A
auf die erste Zelle bezieht.

Aber vielleicht geht es so, wenn wir den kleinsten Wert aus A nehmen und in Spalte B Zählen.
Im Beispiel alles was größer 4 ist.

 ABCD
1192  
243 5
354  
462  
575  
686  
797  
8102  
9115  
10126  
1113   
1214   
1315   
1416   
1517   
1618   
1719   

Formeln der Tabelle
ZelleFormel
D2=ZÄHLENWENN(B1:B1000;">"&MIN(A1:A1000))



Gruß Tino


  

Betrifft: So geht es auch nicht! von: Matthias5
Geschrieben am: 15.12.2009 12:26:03

Hallo Tino,

diese Formel zählt die Werte in B, die größer sind als 4 (Minimum Spalte A).
Boris hat ja die Lösung schon gebracht.

Gruß,
Matthias


  

Betrifft: aber die 5,6 u. 7 von: Tino
Geschrieben am: 15.12.2009 12:32:02

Hallo,
ist doch größer als der kleinste in Spalte A oder habe ich die Frage falsch verstanden?

Gruß Tino


  

Betrifft: Die Frage war eine andere... von: Matthias5
Geschrieben am: 15.12.2009 12:34:51

Hallo Tino,

es sollten jeweils die beiden Werte derselben Zeile verglichen werden.

Gruß,
Matthias


  

Betrifft: ach so, dann habe ich falsch gelesen. oT. von: Tino
Geschrieben am: 15.12.2009 12:36:29




  

Betrifft: demnach hier eine andere Variante von: Tino
Geschrieben am: 15.12.2009 12:54:40

Hallo,
die von Boris ist zwar kürzer aber nach dem Missverständnis eine Lösungsvariante.

 ABCD
1192 Anzahl kleiner als in A
243 9
354  
462 Anzahl größer als in A
574 1
687  
756  
8102  
9110  
10121  
1113   
1214   
1315   
1416   
1517   
1618   
1719   

Formeln der Tabelle
ZelleFormel
D2{=SUMME(WENN((A1:A17>B1:B17)*(A1:A17<>"")*(B1:B17<>""); (A1:A17>B1:B17)*1))}
D5{=SUMME(WENN((A1:A17<B1:B17)*(A1:A17<>"")*(B1:B17<>""); (A1:A17<B1:B17)*1))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen




Gruß Tino


Beiträge aus den Excel-Beispielen zum Thema "Zählen wenn Wert größer ist als anderer Wert"