Prüfen ob Zelle nur Buchstaben und Zeichen enthält

Bild

Betrifft: Prüfen ob Zelle nur Buchstaben und Zeichen enthält
von: Mike
Geschrieben am: 30.10.2015 16:41:32

Hallo,
ich möchte gerne prüfen, ob eine Zelle X nur Buchstaben und Zeichen, also keine Ziffern enthält und falls dies der Fall ist, den Zellwert der aktuellen Zelle auf "n/a" ändern.
Bisher verwende ich dazu folgende Formel (z.B. in J2), die auch funktioniert, ich würde aber gerne die vielen If Statements vermeiden und suche daher nach einem einfacheren Weg.
Mich interessieen nur zwei Szenarien:
1: Zelle X enthält nichts oder nur Buchstaben und Zeichen: dann soll J2 = "n/a" anzeigen
2: Zelle X enthält eine Zahl: dann soll J2 "gültig" anzeigen
Meine Formel (vereinfacht):

=IF(E2="";"n/a";IF(E2="n/a";"n/a";IF(E2="?";"n/a";IF(E2="???";"n/a";IF(E2="none";"n/a";"gültig"))))) 
Kann mir jemand damit helfen ?
Vielen Dank im Voraus,
Mike

Bild

Betrifft: AW: Prüfen ob Zelle nur Buchstaben und Zeichen enthält
von: Mike
Geschrieben am: 30.10.2015 16:49:51
...hat sich erledigt - hab die Lösung selber gefunden...
Danke,
Mike

Bild

Betrifft: AW: Prüfen ob Zelle nur Buchstaben und Zeichen enthält
von: selli
Geschrieben am: 30.10.2015 16:53:17
hallo mike,
beiträge landen irgendwann im archiv.
dann wäre es gut wenn forenbesucher mit ähnlichen problemen auch eine lösung finden.
dass du selber fündig geworden bist, ist in diesem fall für dich sehr schön, aber die anderen laufen bei der recherche zu diesem thread in eine sackgasse.
teile deine lösung mit allen.
gruß
selli

Bild

Betrifft: Zahl in Zelle enthalten ?
von: WF
Geschrieben am: 30.10.2015 17:24:50
=WENN(SUMMENPRODUKT(ISTZAHL(TEIL(A1;ZEILE(1:99);1)*1)*1);"gültig";"n/a")
WF

Bild

Betrifft: AW: Zahl in Zelle enthalten ?
von: Daniel
Geschrieben am: 30.10.2015 20:09:37
Hi
meine Variante:

{=WENN(MIN(LÄNGE(WECHSELN(A1;ZEILE($A$1:$A$10)-1;"")))=LÄNGE(A1);"n/a";"gültig")}
ist ein büschn schneller und funktioniert ohne Änderung mit beliebig langen Texten.
man muss aber die Eingabe immer mit STRG+SHIFT+ENTER abschließen.
Gruss Daniel

Bild

Betrifft: AW: Zahl in Zelle enthalten ?
von: Luschi
Geschrieben am: 30.10.2015 21:07:00
Hallo Daniel,
diese Aussage von Dir: "und funktioniert ohne Änderung mit beliebig langen Texten"
ist FALSCH, denn wenn die Ziffer erst an 11. Stelle steht ergibt die Formel 'gültig',
obwohl eine Ziffer in Text vorhanden ist.
Gruß von Luschi
aus klein-Paris

Bild

Betrifft: das kapierst wohl nur Du ?
von: WF
Geschrieben am: 30.10.2015 21:27:51
"wenn die Ziffer erst an 11. Stelle steht ergibt die Formel gültig"
so soll es ja sein (könnte auch an 47. sein)
aber, jetzt kommst:
"obwohl eine Ziffer in Text vorhanden ist"
welche Logik soll das sein ?
WF

Bild

Betrifft: ZEILE(A1:A10)-1 kannst Du einbauen
von: WF
Geschrieben am: 30.10.2015 21:34:26
=WENN(SUMMENPRODUKT(ISTZAHL(FINDEN(ZEILE(1:10)-1;A1))*1);"gültig";"n/a")
WF

Bild

Betrifft: AW: ZEILE(A1:A10)-1 kannst Du einbauen
von: Daniel
Geschrieben am: 30.10.2015 21:46:48
Hi
das ist wahrscheinlich sogar noch schneller.
hat Zeile(1:10) irgend einen Vorteil gegenüber Zeile(A1:A10).
ich bevorzuge eigentlich letzteres, weil damit die Anzahl der Zellen, die eine unnötige Neuberechnung auslösen können, deutlich kleiner ist.
Gruss Daniel

Bild

Betrifft: Vorteil: sicher nicht
von: WF
Geschrieben am: 30.10.2015 21:58:14
Hi,
aber gibt es zwischen ZEILE(1:10) und ZEILE(A1:A10) einen messbaren Unterschied ?
Hat das mal jemand getestet ?
Ich lasse mich gern belehren
WF

Bild

Betrifft: AW: Vorteil: sicher nicht
von: Daniel
Geschrieben am: 30.10.2015 22:05:08
Hi
da geht nicht um die Geschwindigkeit der Formelberechnung.
aber bei Zeile(1:10) wird die Formel neu berechnet, wenn du in Zelle B1 oder auch in ZZ10 einen Wert änderst obwohl das nicht notwendig ist.
dh wenn du die Formel in einer Tabelle einsetzt, in der du noch aktiv arbeitest, dann ist das schon fast wie ein "Indirekt" in der Formel
Gruss Daniel

Bild

Betrifft: Schreib endlich mal eigene Betreffs
von: WF
Geschrieben am: 30.10.2015 22:27:42
dieses
AW: Wiederholung
ist nur einfallslos und grauenhaft
Das was Du betr. (A1:A10) versus (1:10) sagst, klingt plausibel.
WF

Bild

Betrifft: AW: fkjk fr j lwefoprf
von: Daniel
Geschrieben am: 30.10.2015 22:43:18
Einfach nur den ersten Satz des Beitrags als Überschrift zu verwenden ist genauso einfallslos.
Für Menschen, die mit der Beitragsliste arbeiten wird es dann auch schwerer zu erkennen, auf welche Beiträge sich die neuen Beiträge beziehen.
Gruss Daniel

Bild

Betrifft: tolle Archivsuche
von: WF
Geschrieben am: 31.10.2015 08:16:07
Der Ursprungsbeitrag ist:
"Ich hab ein Formelproblem"
darunter folgt dann 20 mal:
"AW: Ich hab ein Formelproblem"
Man erkennt natürlich sofort, dass in Nr. 17 eine brilliante Lösung stecken muss.
WF

Bild

Betrifft: Zusammenfassung u.Weiteres
von: Luc:-?
Geschrieben am: 31.10.2015 01:51:43
Da deine Anforderung wohl etwas missverstanden wurde, Mike,
fasse ich nachfolgend mal zusammen. Von einzelner Ziffer ist bei dir nirgends die Rede, nur von Zahl, wobei aber nicht ganz klar wird, ob du nur die in deiner Fml aufgeführten Fälle ausgrenzen willst, 'n/a' deutet darauf hin, oder alles, was keine (echte) Zahl ist. Immerhin schreibst du, Zitat: ich würde aber gerne die vielen If Statements vermeiden und suche daher nach einem einfacheren Weg.
Der wurde dir mE nicht gezeigt, sondern nur andere, sogar mit voneinander abweichenden Ergebnissen. Also habe ich mich nach deiner Vorgabe gerichtet (Variante 2) bzw den einfachsten Fall angenommen (Var 1):

 ABCDEFG
1WertMikeWFDanielLuc-1Luc-2.1Luc-2.2
2 n/an/an/an/an/an/a
312gültiggültiggültiggültiggültiggültig
4x1gültign/agültign/agültiggültig
5xx/zzgültign/an/an/agültiggültig
61/2gültign/agültign/agültiggültig
7n/an/an/an/an/an/an/a
8nonen/an/an/an/an/an/a
9?n/an/an/an/an/an/a
10???n/an/an/an/an/an/a
11abcdefghijkgültign/an/an/agültiggültig
12abc 1 def 2 xgültiggültiggültign/agültiggültig
13B2[:B12]:=WENN(A2="";"n/a";WENN(A2="n/a";"n/a";WENN(A2="?";"n/a";WENN(A2="???";"n/a";WENN(A2="none";"n/a";"gültig")))))
14C2[:C12]:=WENN(SUMMENPRODUKT(ISTZAHL(TEIL(A2;ZEILE(1:99);1)*1)*1);"gültig";"n/a")
15D2[:D12]: {=WENN(MIN(LÄNGE(WECHSELN(A2;ZEILE($A$2:$A$10)-1;"")))=LÄNGE(A2);"n/a";"gültig")}
16E2[:E12]:=WAHL(ISTZAHL(A2)+1;"n/a";"gültig")
17F2[:F12]:=WAHL(ODER(A2={""."n/a"."?"."???"."none"})+1;"gültig";"n/a")
18G2[:G12]:=WENN(ODER(A2={""."n/a"."?"."???"."none"});"n/a";"gültig")

Gruß, Luc :-?

Besser informiert mit …

Bild

Betrifft: Nun würde mich ebenso wie Selli nur noch ...
von: Luc:-?
Geschrieben am: 31.10.2015 01:55:47
…interessieren, wie deine Lösung aussieht, Mike… ;-)
Luc :-?

Bild

Betrifft: AW: Zusammenfassung u.Weiteres
von: Daniel
Geschrieben am: 31.10.2015 10:45:41
Hi Luc
deine Formelzusammenstellung enthält noch zwei Fehler:

C2[:C12]:=WENN(SUMMENPRODUKT(ISTZAHL(TEIL(A2;ZEILE(1:99);1)*1)*1);"gültig";"n/a")

Die Formel ist für C2 noch richtig, aber wenn du sie bis C12 kopieren willst, musst du in Zeile(1:99) den Zellbezug absolut setzen, denn dieser muss auch in C12 noch 1:99 sein.
D2[:D12]: {=WENN(MIN(LÄNGE(WECHSELN(A2;ZEILE($A$2:$A$10)-1;"")))=LÄNGE(A2);"n/a";"gültig")}

falsch ist: Zeile($A$2:$A$10)
das muss lauten: Zeile($A$1:$A$10)
ansonsten muss man schon unterscheiden, welchen Fall man prüfen will:
a) Zellewert enthält mindestens eine Ziffer
b) Zellwert ist eine Zahl
c) Zellwert ist ein Text, welcher aber in eine Zahl wandelbar ist
und nach Mikes erstem Satz in seiner Fragestellung ging es ihm um Fall a).
Gruss Daniel

Bild

Betrifft: Stimmt, habe ich bei WF übersehen, ...
von: Luc:-?
Geschrieben am: 31.10.2015 14:53:28
…Daniel;
dann käme das Gleiche raus wie bei deiner Fml, in die sich dieser Fehler nachträglich durch Verschieben eingeschlichen hatte.
Alles Andere stimmt aber und wir wdn wohl nie erfahren, was Mike real im Sinn hatte und dann deshalb gemacht hat.
Gruß, Luc :-?

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Prüfen ob Zelle nur Buchstaben und Zeichen enthält"