Herbers Excel-Forum - das Archiv

Daten eines Blattes auf mehrere verteilen?

Bild

Betrifft: Daten eines Blattes auf mehrere verteilen?
von: Aussie

Geschrieben am: 19.04.2005 07:41:51
Hallo zusammen
Ich habe ein Hauptdatenblatt, dass in der Spalte A ein Code hat. Z.Bsp. 001 oder 002 oder 003 usw.
in Spalte B-E befinden sich dann Adressen von Hotels.
Ich möchte nun, von meinem Datenblatt 1 alle Adressen mit Code "001" ins Datenblatt 2 kopieren und die mit Code "002" ins Datenblatt 3 usw.
Änderungen möchte ich grundsätzlich nur im Datenblatt 1 vornehmen und diese sollen dann automatisch im entsprechenden Datenblatt korrigiert werden. Zudem sollen hinzugefügte Datensätze im Datenblatt 1 auch automatisch in das entsprechende Datenblatt kopiert werden.
Kann mir jemand helfen, wie ich das hinbekomme?
Besten Dank und Gruss
Aussie
Bild

Betrifft: ohne VBA:
von: Günther Oppold

Geschrieben am: 19.04.2005 12:26:23
Hi Aussie,
hier mein Vorschlag ohne VBA
in Tabelle2 Spalte A sind ARRAY-Formeln, die geschweiften Klammern nicht eingeben, sondern die Formeleingabe abschließen mit Strg+Umsch+Enter
Tabelle1
 ABCD
1CodeHotelStr.Ort
2001Hotel1Str. 1Ort 1
3002Hotel2Str. 2Ort 2
4001Hotel3Str. 3Ort 3
5003Hotel4Str. 4Ort 4
6002Hotel5Str. 5Ort 5
7001Hotel6Str. 6Ort 6
8003Hotel7Str. 7Ort 7
9001Hotel8Str. 8Ort 8
10001Hotel9Str. 9Ort 9
 
Tabelle2
 ABCD
1ausblenden:Code001 
22Hotel1Str. 1Ort 1
34Hotel3Str. 3Ort 3
47Hotel6Str. 6Ort 6
59Hotel8Str. 8Ort 8
610Hotel9Str. 9Ort 9
7#ZAHL!   
Formeln der Tabelle
A2 : {=KKLEINSTE(WENN(Tabelle1!A$1:A$65000=Tabelle2!$C$1;ZEILE(Tabelle1!A$1:A$65000));ZEILE(1:1))} B2 : =WENN(ISTFEHLER($A2);"";INDIREKT(ADRESSE($A2;SPALTE();;;"Tabelle1"))) C2 : =WENN(ISTFEHLER($A2);"";INDIREKT(ADRESSE($A2;SPALTE();;;"Tabelle1"))) D2 : =WENN(ISTFEHLER($A2);"";INDIREKT(ADRESSE($A2;SPALTE();;;"Tabelle1"))) </table></td></tr></table></td></tr><tr><td> </td></tr></tr></table> <span style=" font-size:9pt;"><b>Excel Tabellen einfach im Web darstellen</b> <a style ="color:#1506F7; background-color:#FCF507; font-weight:bold;" href="http://www.haserodt.de/ejh_do/ex_jean_info.htm" target="blank">  Excel Jeanie HTML  2.0    Download  </a></span> Günther
Bild

Betrifft: AW: Daten eines Blattes auf mehrere verteilen?
von: Herbert
Geschrieben am: 19.04.2005 12:27:56
Hi,
das ist was für Access, in Excel musst du das alles selbst programmieren, bei deinen
Kenntnissen unmöglich.
mfg Herbert
Bild

Betrifft: AW: Daten eines Blattes auf mehrere verteilen?
von: Fritz

Geschrieben am: 19.04.2005 12:31:50
Hi Aussie,

Dein Problem kann man nur über einen VBA-Code lösen.
Du willst also aus einer Gesamtübersicht für alle Hoteladressen nach einem bestimmten Code alle entsprechnden Adressen in einzelne Tabellenblätter eintragen? Code = Tabellenblattname?
Wie erfolgen die Änderungen in Deinem Datenblatt 1? In einer Datenmaske oder suchst Du diese in der Tabelle und nimmst dann die Änderungen vor?!
Fritz
Bild

Betrifft: AW: Daten eines Blattes auf mehrere verteilen?
von: Aussie

Geschrieben am: 19.04.2005 21:58:37
Hallo Fritz
der Code ist muss nicht zwingend der Tabellenname sein - wäre aber eine Möglichkeit!
Die Änderungen im Datenblatt 1 erfolgen manuell, nicht in einer Datenmaske.
Danke für die Hilfe.
 Bild
Excel-Beispiele zum Thema "Daten eines Blattes auf mehrere verteilen?"
Name des vorhergehenden Blattes Tabellencode nach Kopieren des Blattes löschen
Zeilen eines zweiten Blattes im ersten über Drehfeld anzeigen Den in einer Zelle genannten Bereich eines Blattes drucken
Legende eines Datenblattes einschließlich der Farbmarkierung Kopieren und Umbenennen eines Blattes
Die letzte Zeile des aktiven Blattes in andere Arbeitsmappe CheckBox-Werte eines Blattes in ein anderes Blatt eintragen
Bei Aktivieren eines Arbeitsblattes ComboBox neu einlesen Auswahl des jeweils nächsten Blattes