Microsoft Excel

Herbers Excel/VBA-Archiv

Tabelle nach bestimmten Suchkriterien filtern

Betrifft: Tabelle nach bestimmten Suchkriterien filtern von: Angel83
Geschrieben am: 17.08.2004 12:32:35

Hallo,

ich habe eine Tabelle mit den Salden verschiedener Konten, z.B.

A B C

12345 2000,00 18.05.2004
12345 1500,00 19.05.2004
54321 300,00 19.05.2004
12345 1200,00 21.06.2004
54321 1000,00 25.06.2004


Nun möchte ich gerne ein Tabellenblatt für jedes Konto erstellen, in dem nur die Salden und das Datum des jeweiligen Kontos angezeigt wird (Suchkriterium soll ein Zellbezug sein).
Außerdem hätte ich gerne noch ein Liniendiagramm, indem ich die Salden der beiden Konten vergleichen kann (x-Achse = Datum, y-Achse = Saldo).

Ich habe leider keinen Plan, wie ich das anstellen soll, da ich mich in Excel nicht so sehr auskenne, was komplizierte Formeln betrifft.

Freue mich schon auf eure Antworten.

Viele Grüße,
Anja

  


Betrifft: AW: Tabelle nach bestimmten Suchkriterien filtern von: Thomas
Geschrieben am: 18.08.2004 16:33:18

Hallo Anja,

mit dem Diagramm kann ich dir leider auch nicht helfen.
Aber wenn ich dich bei deiner richtig verstanden habe, könnte das etwa so aussehen:

in Tabelle 1 steht ja wie du ´geschrieben hast:
A B C

12345 2000,00 18.05.2004
12345 1500,00 19.05.2004
54321 300,00 19.05.2004
12345 1200,00 21.06.2004
54321 1000,00 25.06.2004

wenn jetzt in Tabelle2 die Salden von Konto 12345 erscheinen sollen lautet die Formel so:

{=WENN(ZEILEN($1:1)>ZÄHLENWENN(Tabelle1!$A$1:$A$5;12345);"";INDEX(Tabelle1! $B$1:$B$5;KKLEINSTE(WENN((Tabelle1!$A$1:$A$5=12345);ZEILE($1:$5));ZEILEN($1:1))))}

Dann übernimmt er alle salden von dem Konto 12345 (einacher wäre es wenn du z.B. in Tabelle 2 in A1 "12345" reinschreibst, dann kann sich die Formel auf die Zeile beziehen
z.B. ...Zählenwenn(Tabelle1!$A$1:$A$5;Tabelle2!$A$1...

Die Formel musst du dann runterkopieren. Beim Datum das gleiche, ausser das du statt Spalte B, Spalte C in die die Formel eingibst.
USW

GANZ WICHTIG:
DEamit die Formel richtig rechnet, sind die geschweiften Klammern wie oben angezeigt wichtig, die musst du aber nicht eingeben, sondern du bestätigst die Formel nicht nur mit Enter, sonder mit der Kombination STRG,SHIFT,ENTER

so müsste das eigentlich funktionieren.

Ich hoffe ich ko0nnte dir ein bischen helfen.


  


Betrifft: AW: Tabelle nach bestimmten Suchkriterien filtern von: Angel83
Geschrieben am: 19.08.2004 08:21:35

Vielen Dank Thomas, so hat das ganze funktioniert. :-) Wo lernt man solche Formeln nur? *seufz* Naja, hauptsache es geht.

Vielen lieben Dank,
Anja


 

Beiträge aus den Excel-Beispielen zum Thema "Tabelle nach bestimmten Suchkriterien filtern"