Microsoft Excel

Herbers Excel/VBA-Archiv

SVERWEIS *NV unterdrücken | Herbers Excel-Forum


Betrifft: SVERWEIS *NV unterdrücken von: Frank
Geschrieben am: 09.02.2012 08:22:15

Hallo Zusammen , ich habe einen Verweis.

=WENN(ISTFEHLER(SVERWEIS(S351;Verantwortung!$A$1:$B1346;2));"";SVERWEIS(S351; Verantwortung!$A$1:$B1346;2;FALSCH)) 
aber sowohl ISTFEHLER als auch ISTNV unterdrückt nicht die Ausgabe #NV wenn kein Wert gefunden wird.

Wo liegt der Fehler?

Vielen Dank schon mal

Gruß
Frank

  

Betrifft: AW: SVERWEIS *NV unterdrücken von: selli
Geschrieben am: 09.02.2012 08:48:24

hallo frank,

also der aufbau der formel ist richtig,
nur fehlt bei der formel, die überprüft werden soll, ob sie den fehler auslöst das letzte attribut "FALSCH")

ergänze das doch mal, dann sind beide teilformeln identisch.

gruß
selli


  

Betrifft: AW: SVERWEIS *NV unterdrücken von: Frank
Geschrieben am: 09.02.2012 09:03:23

Hallo selli,

irgendwie stehe ich gerade auf dem Schlauch und weiß nicht genau was Du meinst

Gruß Frank


  

Betrifft: AW: SVERWEIS *NV unterdrücken von: selli
Geschrieben am: 09.02.2012 09:06:33

hallo frank,

deine formel bislang:
=WENN(ISTFEHLER(SVERWEIS(S351;Verantwortung!$A$1:$B1346;2));"";SVERWEIS(S351; Verantwortung!$A$1:$B1346;2;FALSCH)) ~f~

ändern in:
~f~=WENN(ISTFEHLER(SVERWEIS(S351;Verantwortung!$A$1:$B1346;2;Falsch));"";SVERWEIS(S351; Verantwortung!$A$1:$B1346;2;FALSCH))

gruß selli


  

Betrifft: ohne ~f~ natürlich von: selli
Geschrieben am: 09.02.2012 09:07:57

.


  

Betrifft: AW: SVERWEIS *NV unterdrücken von: Frank
Geschrieben am: 09.02.2012 09:15:07

Hallo selli,

tausend Dank.

Gruß Frank


  

Betrifft: hört bitte auf, das arme Excel zu quälen... von: silex1
Geschrieben am: 09.02.2012 09:23:17

hi,

ISTFEHLER() ist bei SVERWEIS() nicht notwendig, denn es kann nur #NV zurückgegeben werden. Daher ISTNV() verwenden, so muss das arme Excel nicht alle Fehler durchforsten.

VG, Rene


  

Betrifft: Sehr richtig! Musste wohl mal gesagt wdn! orT von: Luc:-?
Geschrieben am: 09.02.2012 15:32:48

Gruß Luc :-?


Beiträge aus den Excel-Beispielen zum Thema "SVERWEIS *NV unterdrücken"