Live-Forum - Die aktuellen Beiträge
Datum
Titel
17.06.2024 19:56:24
17.06.2024 19:39:46
Anzeige
Archiv - Navigation
1848to1852
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Wenn #NV dann...

Wenn #NV dann...
07.10.2021 12:17:24
Azat
Hallo,
gibt es hierfür eine Formel?
in einer Spalte bsp beginnt mit Zelle:A1 soll hochgezählt werden von 1 bis n+1.
Sobald ein #NV erscheint, den diese Zelle als Bezug nimmt soll diese Zelle(A1 und fortlaufend), dieses #NV überspringen,nicht beachten und nicht hochzählen sondern erst wieder wenn kein #NV erscheint.
Bsp::
A B
1 235
2 54
#NV
3 32847
#NV
#NV
4 2328
Danke und einen angenehmen Tag

9
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Wenn #NV dann...
07.10.2021 12:23:13
{Boris}
Hi,
in A1 steht die Zahl 1.
In A2:
=WENN(ISTZAHL(B2);MAX(A$1:A1;A1)+1;"")
und runterkopieren.
Besser wäre es allerdings, #NV zu vermeiden.
VG, Boris
AW: Wenn #NV dann...
07.10.2021 12:44:31
Azat
Hallo Boris,
danke dir, aber die Zahlen werden nur übersprungen. Ich meinte eigentlich, dass die Zelle weiterzählen soll erst wenn kein #NV gefunden ist.
Das heißt es könnte sein, dass nach 50 #NV in A2, die Fortlaufendenummer 4 steht.
Danke Gruß Azat
AW: unklar was Du hast und genau anstrebst ...
07.10.2021 12:55:58
neopa
Hallo Azat,
... ich hätte in A1 folgende Formel vorgeschlagen:
=WENN(ISTNV(B1);"";AGGREGAT(2;;B$1:B1)) und diese nach unten kopiert mit dem gleichen Ergebnis wie mit der Formel von {Boris}.
Aber Dein Beitrag nach seinen Formelvorschlag kann ich nicht nachvollziehen. Dazu stell doch mal (D)eine Beispieldatei ein und erkläre daran.
Gruß Werner
.. , - ...
AW: unklar was Du hast und genau anstrebst ...
07.10.2021 13:19:33
Azat
Hallo Werner,
wie wäre die Formel wenn in B nicht nur Zahlen stehen würden sondern text?
Danke
AW: Wenn #NV dann...
07.10.2021 13:12:29
Günther
Moin,
gleicher Wunsch wie Werner: Ohne Muster-xlsx mit händischer Lösung => Glaskugel. Die aber sagt mi, dass das in deiner Version mit Power Query lösbar ist.
 
Gruß
Günther  |  mein Excel-Blog
Anzeige
AW: Wenn #NV dann...
07.10.2021 13:44:48
{Boris}
Hi,
ist doch eigentlich genau so wie bereits vorgeschlagen.
E3:
=WENN(ISTNV(F3);"";MAX(E$2:E2;E2)+1)
und runterkopieren.
VG, Boris
AW: Wenn #NV dann...
07.10.2021 13:32:22
Daniel
Hi
also ich gehe mal davon aus, dass das #NV in Spalte B steht.
dann so:
in A1 die Formel: =Wenn(IstNV(B1);"";1)
ab A2 bis zum Ende die Formel: =Wenn(IstNV(B2);"";Wenn(IstNV(B1);Max(A$1:A1)+1;A1+1))
beachte bitte zukünftig, wenn du Tabellenauschnitte hier im Forum zeigen willst, dass die Forensoftware normale Leerzeichen am Anfang einer Zeile löscht und somit Einrückungen per Leerzeichen nicht wirksam werden, wodurch deine Tabelle falsch angezeigt wird.
am besten ist, solche Tabellendarstellungen auch wie Code als "Zitat" zu formatieren.
Dann bleiben nicht nur die Leerzeichen am Anfang einer Zeile erhalten, sondern es wird auch die Schriftart Courier verwendet, die es als nichtproportionalschrift erlaubt, Textteile per Leerzeichen genau zu positionieren.
Gruß Daniel
Anzeige

309 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige