Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
"-" durch "0" ersetzen
16.04.2009 10:46:12
Flo
Hallo zusammen,
nachdem man in diesem Forum immer sehr schnell, sehr gute Antworten bekommt, meine zweite Frage nach ;-)
Ich habe in manchen Zellen "-" stehen. Gibt es die Möglichkeit diese "-" durch z.B. eine "0" zu ersetzen?
Also eine Formel, die mir in C3 eine "0" gibt wenn z.B. in Zelle C2 "-" steht
Vielen Dank, Flo :-)

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: "-" durch "0" ersetzen
16.04.2009 10:49:08
Erwin
Hallo Flo
meinst du so:
C3 = wenn(C2="-";0;"")
Gruss Erwin
mit wechseln()
16.04.2009 10:56:22
heikoS
Hallo Flo,
schau Dir ´mal die Funktion wechseln() an.
Klappt´s?
Gruß Heiko
Wenn nicht "-"
16.04.2009 11:12:51
Flo
Hallo,
also ich komme mit beiden Formeln ans Ziel :-)
Allerdings habe ich eine Sache nicht bedacht. Ich möchte die Formel runterkopieren. Wenn jetz aber kein"-" in Spalte C steht sonder eine Zahl dann dann bleibt die entsprechende Zelle leer.
Es wäre für mich aber wichtig, dass dann die Zahl in die entsprechende Zelle kopiert wird.
also: C1: "-" -- D1: "0"
C2: "100" -- D2: "100"
Ist das überhaupt möglich?
Danke für eure Antworten
Anzeige
AW: Wenn nicht "-"
16.04.2009 11:22:53
David
Hallo.
dann so:
=WENN(C1="-";0;C1)
das kannst du dann runterkopieren.
Gruß
David
AW: Wenn nicht "-"
16.04.2009 11:22:55
Erich
Hi Flo,
vielleicht so? (Formnel von D2 nach unten kopieren)
 CD
2-0
3aa
455
5-5-5

Formeln der Tabelle
ZelleFormel
D2=WENN(C2="-";0;C2)

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort
Anzeige
AW: "-" durch "0" ersetzen
16.04.2009 11:17:51
ede
Hallo Flo,
dann frag vorher auf zahl ab:
wenn(istzahl(DeineZelle);DeineZelle;wechseln(....))
Gruss

317 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige