Microsoft Excel

Herbers Excel/VBA-Archiv

Sortierung nach RANG in neuer Spalte mit Namen | Herbers Excel-Forum


Betrifft: Sortierung nach RANG in neuer Spalte mit Namen von: Martin
Geschrieben am: 10.08.2012 14:13:52

Hallo,
ich habe ein Zeitauswertungs-Sheet erstellt, welches nun fast fertig ist.
Mir fehlt jetzt am Ende "nur" noch eine neue Sortierung nach Rang.
Die Plätze (RANG....) sind zwar schon ermittelt, aber noch nicht nach 1,2,3, ... usw sortiert.

Spalten A,B, und C sollen nicht verändert/neu sortiert werden (sind Alphabetisch)
Es sollen in zwei neuen Spalten (hier E und F) die Plätze und die Namen (nach Platz) sortiert angezeigt werden.

Datei: https://www.herber.de/bbs/user/81367.xlsx

  

Betrifft: AW: Sortierung nach RANG in neuer Spalte mit Namen von: Matze,Matthias
Geschrieben am: 10.08.2012 14:28:06

Hallo Martin,
so??

https://www.herber.de/bbs/user/81368.xlsx

Matze


  

Betrifft: AW: Sortierung nach RANG in neuer Spalte mit Namen von: Uwe (:o)
Geschrieben am: 10.08.2012 17:26:44

Hallo Martin,
ich denke, das könnte SO klappen:
Tabelle1

 ABCDEF
1NameZeitPlatz PlatzName
2Anna39,89210 1Markus1
3Hanna32,2714 2Peter
4Helmut31,9933 3Helmut
5Klaus238,4449 4Hanna
6Klaus34,9346 4Zorro
7Markus131,5441 6Klaus
8Markus234,9877 7Markus2
9Otto36,8718 8Otto
10Peter31,9212 9Klaus2
11Zorro32,2714 10Anna
12      
13      
14      

Formeln der Tabelle
ZelleFormel
E2=WENNFEHLER(INDEX($C$2:$C$98;VERGLEICH(F2;$A$2:$A$98;0)); "")
F2{=WENNFEHLER(INDEX($A$2:$A$98;VERGLEICH(KKLEINSTE(WENN(B$2:B$98>0;B$2:B$98+ZEILE($2:$98)/9^9;9^9); ZEILE(A1)); B$2:B$98+ZEILE($2:$98)/9^9;0)); "")}
E3=WENNFEHLER(INDEX($C$2:$C$98;VERGLEICH(F3;$A$2:$A$98;0)); "")
F3{=WENNFEHLER(INDEX($A$2:$A$98;VERGLEICH(KKLEINSTE(WENN(B$2:B$98>0;B$2:B$98+ZEILE($2:$98)/9^9;9^9); ZEILE(A2)); B$2:B$98+ZEILE($2:$98)/9^9;0)); "")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
E21. / Zellwert ist zwischen =4 und =10Abc
E22. / Zellwert ist gleich =3Abc
E23. / Zellwert ist gleich =2Abc
E24. / Zellwert ist gleich =1Abc
E25. / Zellwert ist gleich =3Abc
E31. / Zellwert ist zwischen =4 und =10Abc
E32. / Zellwert ist gleich =3Abc
E33. / Zellwert ist gleich =2Abc
E34. / Zellwert ist gleich =1Abc
E35. / Zellwert ist gleich =3Abc


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Ich habe mir dafür hier:
http://www.excelformeln.de/formeln.html?welcher=137
Hilfe geholt.

Gruß
Uwe
(:o)


  

Betrifft: AW: Sortierung nach RANG in neuer Spalte mit Namen von: Martin
Geschrieben am: 10.08.2012 15:16:42

Hi matze,
ja, sieht schon so aus wie gewünscht.
Die Namen aus A muss ich aber erst in F alle eintrage, korrekt?
Falls ich also weitere Teilnehmer habe, die Namen von A nach F "kopieren" und den Bereich entsprechend erweitern.
Ein automatismus, das Excel selbst die Namen aus A nimmt und den Rang korrekt sortiert, geht wohl nicht (so einfach) ?


  

Betrifft: AW: Sortierung nach RANG in neuer Spalte mit Namen von: Nadine
Geschrieben am: 10.08.2012 17:09:55

Das wäre meine Löstung gewesen... Dann musst du die Namen nicht selbt übernehmen...

https://www.herber.de/bbs/user/81373.xls


Schönes Wochenende!


  

Betrifft: AW: Sortierung nach RANG in neuer Spalte mit Namen von: Josef Ehrensberger
Geschrieben am: 10.08.2012 20:37:51



« Gruß Sepp »



  

Betrifft: Falsche Datei! von: Josef Ehrensberger
Geschrieben am: 10.08.2012 20:44:43



« Gruß Sepp »



Beiträge aus den Excel-Beispielen zum Thema "Sortierung nach RANG in neuer Spalte mit Namen"