variable Bereich (Summ) VBA

Bild

Betrifft: variable Bereich (Summ) VBA
von: hachim
Geschrieben am: 27.07.2015 18:54:37


Hallo zusammen,

ich bin ein Anfänger bei VBA und habe ein Problem, wo Ihr mir vllt dabei helfen könntet.
wie unten auf dem Bild zu sehen ist, habe ich drei spalte. in der ersten Spalte gibt es n Typen (Variable). das heisst jedes mal kann sich die Anzahl der A-Typ (B,C...Typ ändern.
für jeden Typ wird einen wert in der Spalte B ausgegben. Die summe alle dieser Werte (zb. hier für A-typ von B2-B6, für B-Typ von B7-B10 usw) soll in Spalte C für jeden Typ gleich sein. (wie im Bild dargestellt).
PS: es muss via VBA gelöst werden :)
kann mir jemand mit einem bespiel für ein VBA-Code für die Lösung helfen?
vielen Dank im Voraus.

Grüße
Hachim
Userbild

Bild

Betrifft: AW: variable Bereich (Summ) VBA
von: Hajo_Zi
Geschrieben am: 27.07.2015 19:09:39
Hochgeladene Bilder können zwar als solche in Excel importiert werden, sind jedoch bei der Lösung von Problemen nicht sehr hilfreich, da man die eigentlichen Daten nicht ohne große und zeitraubende Umwege direkt in die Tabelle übertragen kann. Eine hochgeladene Arbeitsmappe bzw. ein geposteter Tabellenausschnitt dagegen, erhöhen die Wahrscheinlichkeit, dass Du eine Lösung für Dein Problem erhältst.
Erstelle folglich bitte eine Demomappe, aus der deine Aufgabenstellung klar erkennbar ist und lade diese Mappe mit einem aussagekräftigen Dateinamen hoch oder benutze ein Tool zur Tabellenanzeige.
Der Name einer hochgeladenen Mappe wird im Beitrag automatisch angezeigt, sodass es bei Verwendung von aussagekräftigen Namen leichter fällt, sie später im Ablageordner wiederzufinden und sie gedanklich einem bestimmten Thema zuzuordnen. Namen wie Test, Mappe, Beispiel usw. sind so allgemein, dass eine Zuordnung zu einem Thema unmöglich gemacht wird.
Summewenn()


Bild

Betrifft: So ?
von: robert
Geschrieben am: 27.07.2015 19:35:45
https://www.herber.de/bbs/user/99103.xlsx
Gruß
robert

Bild

Betrifft: AW: Sorry war die falsche Datei....
von: robert
Geschrieben am: 27.07.2015 19:53:32
https://www.herber.de/bbs/user/99105.xlsx
VBA Codes siehe unten von Daniel

Bild

Betrifft: wieso steht in Deinem bild bei Typ-A 25 ??
von: Matthias L
Geschrieben am: 27.07.2015 20:04:32
Hallo
wieso steht in Deinem Bild bei Typ-A 25 ??
bei Formeln geht auch SummeWenns ...
ähnlich roberts Vorschlag.

 ABC
2a1036
3a1236
4a1436
5v1654
6v1854
7v2054
8b22100
9b24100
10b26100
11b28100

Formeln der Tabelle
ZelleFormel
C2=SUMMEWENNS($B$2:$B$11;$A$2:$A$11;A2)
C3=SUMMEWENNS($B$2:$B$11;$A$2:$A$11;A3)
C4=SUMMEWENNS($B$2:$B$11;$A$2:$A$11;A4)
C5=SUMMEWENNS($B$2:$B$11;$A$2:$A$11;A5)
C6=SUMMEWENNS($B$2:$B$11;$A$2:$A$11;A6)
C7=SUMMEWENNS($B$2:$B$11;$A$2:$A$11;A7)
C8=SUMMEWENNS($B$2:$B$11;$A$2:$A$11;A8)
C9=SUMMEWENNS($B$2:$B$11;$A$2:$A$11;A9)
C10=SUMMEWENNS($B$2:$B$11;$A$2:$A$11;A10)
C11=SUMMEWENNS($B$2:$B$11;$A$2:$A$11;A11)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Die VBA-Variante hat Dir schon Daniel aufgezeigt
Gruß Matthias

Bild

Betrifft: AW: wieso steht in Deinem bild bei Typ-A 25 ??
von: hachim
Geschrieben am: 27.07.2015 20:13:24
Hi,
vielen Dank für eure Hilfe.
da mit dem 25 war ein Rechenfehler. sorry.
ich teste gleich und gebe ne Rückmeldung.
Grüße
Hachim

 Bild

Beiträge aus den Excel-Beispielen zum Thema "variable Bereich (Summ) VBA"