Summen in einer Spalte

Bild

Betrifft: Summen in einer Spalte von: okgi
Geschrieben am: 07.02.2005 17:00:39

Hallo!!
Habe ein Problem mit einer riesigen Tabelle!!
Ich möcht gern eine Anzahl von Zahlen, die durch eine Zahl in einem anderen Feld bestimmt wird,aufsummieren.
Beispiel
Tabelle:
0
1
2
3
4
5
6
7
und in einem anderen Feld steht eine 5.
Also sollen die Zahlen von 0 bis 4 aufsummiert werden.

Vielleicht ist es richtig einfach - aber ich komme beim besten Willen nicht auf die Lösung :-(
Vielleicht hat jemand eine Lösung??

mfg,
Ondrej

Bild


Betrifft: summewenn() kleiner 5 von: bernd
Geschrieben am: 07.02.2005 17:20:11

hallo ondre

 
 ABC
11510
22  
33  
44  
55  
66  
77  
88  
99  
1010  
Formeln der Tabelle
C1 : =SUMMEWENN(A1:A25;"<"&B1;A1:A25)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

bernd


Bild


Betrifft: AW: Summen in einer Spalte von: Matthias G
Geschrieben am: 07.02.2005 17:23:23

Hallo Ondrej,

z.B.:
zu summierender Bereich in A1:A10, Grenzwert in B1

dann mit

=SUMMENPRODUKT((A1:A10)*(A1:A10<B1))
oder
=SUMMEWENN(A1:A10;"<"&B1;A1:A10)

Gruß Matthias


Bild


Betrifft: AW: Summen in einer Spalte von: okgi
Geschrieben am: 08.02.2005 16:42:05

Hallo!!
Erst einmal vielen Dank für die Antworten!! : -)
Sie haben zwar dieses Problem nicht lösen können aber dafür das 2. Problem (das ich hier noch nicht eingestellt hatte) gelöst –SUPER DANKE!!
Ich glaube ich habe mich nicht richtig ausgedrückt – deswegen stelle ich einen Teil meiner Tabelle hier ein.
https://www.herber.de/bbs/user/17642.xls
Hier die – hoffentlich bessere Formulierung des Problems:

In der Tabelle sollen alle Werte im gelb markierten Bereich aufsummiert werden. ABER dieser gelb markierte Bereich ist von der Temperatur in Zelle E30 abhängig!! D.h. wenn die Temperatur nicht, wie hier 18,5°C ist, sondern 16,4°C , sollen die Werte der Zellen F3-F21 summiert werden.

Temperatur Bereich der zu summieren ist
13,5 F3:F24
14,5 F3:F23
15,5 F3:F22
16,5 F3:F21
17,5 F3:F20
usw. .....

Hab mir schon den Kopf zerbrochen : -(

Einen schönen Abend wünsche ich !!

Gruß Ondrej


Bild


Betrifft: AW: Summen in einer Spalte von: Matthias G
Geschrieben am: 09.02.2005 05:27:40

Hallo Ondrej,

vielleicht so in F25:
=SUMMENPRODUKT((A3:A24>=E30)*F3:F24)
das rechtet dann intern so so:
(A3>=E30)*F3 + (A4>=E30)*F4 + (A5>=E30)*F5 + (A5>=E30)*F5 * ... + (A24>=E30)*F24
Gruß Matthias


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Summen in einer Spalte"