Live-Forum - Die aktuellen Beiträge
Anzeige
Archiv - Navigation
1392to1396
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

inkrementelles suchen und ersetzen

inkrementelles suchen und ersetzen
03.12.2014 10:51:13
Juergen
hallo,
ich habe einer spalte [A] die uhrzeit [HH:MM:SS] diese ist für eine unbestimmte anzahl an zeilen gleich und ändert sich danach um 1 sekunde, bsp:
[A]:
[12:13:24]
[12:13:24]
[12:13:24]
[12:13:25]
[12:13:25]
[12:13:26]
[12:13:27]
[12:13:27]
[12:13:27]
jetzt möchte ich eine neue spalte [B] in der jede uhrzeit mit einer bestimmten zahl ersetzt wird, welche welche sich immer um 1 erhöht und in einer anderen spalte [C] abgegriffen wird.
[C]
[3]
[4]
[5]
[6]
das ergebnis sollte dann so ausehen:
[B]
[3]
[3]
[3]
[4]
[4]
[5]
[6]
[6]
[6]
leider sind es mehrere 1000 zeilen und ein manuelles suchen und ersetzen würde ewig dauern.
gibt es ideen für ein makro oder hat ecxel etwaige suchfunktionen irgendwo versteckt.
vielen dank und viele grüße
jf

15
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: inkrementelles suchen und ersetzen
03.12.2014 11:29:00
Rudi
Hallo,
warum so kompliziert?
Startzahl in B2 eintragen.
AB
2[12:13:24]3
3[12:13:24]3
4[12:13:24]3
5[12:13:25]4
6[12:13:25]4
7[12:13:26]5
8[12:13:27]6
9[12:13:27]6
10[12:13:27]6

ZelleFormel
B3=WENN(A3=A2;B2;B2+1)

Gruß
Rudi

Anzeige
AW: inkrementelles suchen und ersetzen
03.12.2014 13:23:27
Juergen
wie einfach
vielen dank

AW: inkrementelles suchen und ersetzen
03.12.2014 13:23:32
Juergen
wie einfach
vielen dank

AW: inkrementelles suchen und ersetzen
03.12.2014 13:23:40
Juergen
wie einfach
vielen dank

AW: inkrementelles suchen und ersetzen
03.12.2014 13:23:41
Juergen
wie einfach
vielen dank

AW: inkrementelles suchen und ersetzen
03.12.2014 13:23:41
Juergen
wie einfach
vielen dank

AW: inkrementelles suchen und ersetzen
03.12.2014 13:23:44
Juergen
wie einfach
vielen dank

AW: inkrementelles suchen und ersetzen
03.12.2014 13:23:45
Juergen
wie einfach
vielen dank

AW: inkrementelles suchen und ersetzen
03.12.2014 13:23:52
Juergen
wie einfach
vielen dank

AW: inkrementelles suchen und ersetzen
03.12.2014 13:24:00
Juergen
wie einfach
vielen dank

AW: inkrementelles suchen und ersetzen
03.12.2014 13:24:01
Juergen
wie einfach
vielen dank

AW: inkrementelles suchen und ersetzen
03.12.2014 13:24:01
Juergen
wie einfach
vielen dank

was ist denn da passiert ? owT
03.12.2014 13:36:47
robert

EINfach? Eher ELFfach ;-)) oT
03.12.2014 20:40:50
{Boris}
...

AW: inkrementelles suchen und ersetzen
03.12.2014 11:32:43
daniel
Hi
In B1 kommt die 3
In B2 die Formel: =wenn(a1=a2;b1;b1+1)
Die Formel aus B2 dann nach unten ziehen.
Gruß Daniel
Anzeige

320 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige