Microsoft Excel

Herbers Excel/VBA-Archiv

istzahl erkennt Zahl nicht

Betrifft: istzahl erkennt Zahl nicht von: Franz W.
Geschrieben am: 25.09.2020 16:25:01

Hallo Fachleute,


in einer Zelle wird durch eine wenn-Formel ein Text (Name) oder aber eine Zahl eingetragen. Die Zahl soll durch bed. Format. eine andere Formatierung erhalten.


Mit =ISTZAHL(C22) geht es aber nicht.


Auch umgekehrt, durch =isttext(c22) den Text anders zu formatieren, wird nicht erkannt.


Woran könnte das liegen? An der Formatierung der Zelle? Wenn ja, wie müsste die sein? Ich find's nicht raus.


Danke schonmal und Grüße

Franz

Betrifft: AW: istzahl erkennt Zahl nicht
von: SF
Geschrieben am: 25.09.2020 16:40:41

Hola,

es könnte auch an der geheimen Formel liegen.

Gruß,
steve1da

Betrifft: AW: istzahl erkennt Zahl nicht
von: Franz W.
Geschrieben am: 25.09.2020 17:51:19

sorry, Steve,

ich wollte nix geheim halten:

=WENN(ODER(ISTFEHLER(SVERWEIS(A22;Stammdaten;3;0));A22="");"";SVERWEIS(A22;Stammdaten;3;0)) & " " & WENN(ODER(ISTFEHLER(SVERWEIS(A22;Stammdaten;4;0));A22=""); B22;SVERWEIS(A22;Stammdaten;4;0))

Grüße
Franz

Betrifft: AW: istzahl erkennt Zahl nicht
von: SF
Geschrieben am: 25.09.2020 17:53:53

Hola,

durch das " " erzeugst du TEXT, völlig egal was die Sverweise ergeben.

Gruß,
steve1da

Betrifft: AW: istzahl erkennt Zahl nicht
von: Franz W.
Geschrieben am: 25.09.2020 17:58:24

Gut. Kann ich dann der Zahl in B22 ein Format übergeben? Format(b22)=.... ?

Oder gebe ich damit lediglich der Zahl ein bestimmtes Format ohne an der Zelle was zu ändern?

Oder geht per VBA was? Lässt sich damit die Zelle als Zahl einstellen?

Grüße
Franz

Betrifft: AW: istzahl erkennt Zahl nicht
von: SF
Geschrieben am: 25.09.2020 18:00:12

Hola,

probier mal:
=B22*1
Gruß,
steve1da

Betrifft: andersrum
von: Franz W.
Geschrieben am: 25.09.2020 18:05:40

das geht nicht, Steve,

bleibt immer noch Text. Aber andersrum hab ich's probiert. Und das geht: =ISTZAHL(C22*1) in die bed. Formatierung - so klappt es wie gewünscht.

Danke für deine Hilfe!
Grüße
Franz

Betrifft: AW: andersrum
von: Luschi
Geschrieben am: 25.09.2020 19:46:10

Hallo Franz,

wie jetzt auf einmal der Zugriff auf Zelle 'C22', in der obigen langen Formel kommt diese Zelle überhaupt nicht vor?

fragt sich Luschi
aus klein-Paris

Betrifft: AW: andersrum
von: Franz W.
Geschrieben am: 25.09.2020 19:49:09

Hallo Luschi,

die obigen lange Formel mit B22 steht in der Befehlszeile der Zelle C22 und holt die Werte, ggf den Wert aus B22.

Die kurze Formel mit Istzahl steht in der bedingten Formatierung der Zelle C22 und formatiert diese Zelle.

Grüße
Franz