Microsoft Excel

Herbers Excel/VBA-Archiv

Zelle wird nicht (an)erkannt ?


Betrifft: Zelle wird nicht (an)erkannt ? von: Björn Steinbach
Geschrieben am: 26.01.2018 15:03:20

Moin,

in der Zelle H8 soll die Differenz aus G8-C4 dargestellt werden.

Die Formel dafür lautet :

=WENN(E8=0;"";WENN(G8<$C$4;"";WENN(G8=$C$4;"";WENN(G8>$C$4;G8-$C$4;""))))

Nun ist der Wert in C4 abhängig von dem Wochentag und ändert sich immer dann, wenn der Wochentag ein Freitag ist.

Leider bleibt die Zelle H8 leer, auch wenn die Formel in H8 korrekt ist.
Ich habe den Wert aus C4 in D4 manuel eingetragen, dann funktioniert es.

Es liegt vermutlich an C4 und dem veränderbaren Wert ?

Weis jemand Rat ?


  

Betrifft: AW: Zelle wird nicht (an)erkannt ? von: Björn Steinbach
Geschrieben am: 26.01.2018 15:05:21




  

Betrifft: AW: sanstelle eines Bildes besser eine Datei owT von: ... neopa C
Geschrieben am: 26.01.2018 15:10:08

Gruß Werner
.. , - ...


  

Betrifft: AW: sanstelle eines Bildes besser eine Datei owT von: Björn Steinbach
Geschrieben am: 26.01.2018 15:17:30

stimmt... ist sinnvoller :)

https://www.herber.de/bbs/user/119300.xlsx


  

Betrifft: AW: sanstelle eines Bildes besser eine Datei owT von: fcs
Geschrieben am: 26.01.2018 15:31:06

Hallo Björn,

du musst die Formel in C4 anpassen - sie liefert die Uhrzeit nur als Text:

=WENN(C3="Freitag";ZEIT(6;50;0);ZEIT(7;55;0))

oder
=WENN(C3="Freitag";ZEITWERT("06:50:00");ZEITWERT("07:55:00"))
Gruß
Franz


  

Betrifft: AW: sanstelle eines Bildes besser eine Datei owT von: Björn Steinbach
Geschrieben am: 26.01.2018 16:59:39

Super ! Vielen Dank :)