D5 >= AA1? mit Datum geht nicht



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: D5 >= AA1? mit Datum geht nicht
von: Stefan Köhne
Geschrieben am: 14.06.2002 - 11:53:01

In D5 habe ich 16:30:00 stehen in AA1 dasselbe. Gleiche Formatierung ist sichergestellt. Die Formel =WENN(D5>=AA1;"OK";"NO")liefert mir NO. Schreibe ich in Z1 den Vergleichswert liefert mir die Formel =WENN(D5>=Z1;"OK";"NO")OK. Bei dem Sprung von Spalte Z auf AA funktioniert der >= Vergleich nicht mehr.

Hat jemand eine Idee?

nach oben   nach unten

Re: D5 >= AA1? mit Datum geht nicht
von: Stefan Köhne
Geschrieben am: 14.06.2002 - 12:07:50

Mit einem Versuchsaufbau in einer leeren Arbeitsmappe geht es, mit meiner mit Daten gefüllten Mappe die ich vergleichen möchte nicht. Jetzt bin ich komplett ratlos.

nach oben   nach unten

Re: D5 >= AA1? mit Datum geht nicht
von: andreas e
Geschrieben am: 14.06.2002 - 12:27:15

hallo stefan ,

ist es ebtl. so , daß eine der beiden zellen (oder beide) das ergebnis einer berechnung sind ?

evtl. wäre denkbar einmal steht da wenn man es als Datum und Zeit formatiert (bei 12:00) 00.01.1900 12:00:00.

ist die 2. Zahl der wert einer Berechnung aus Datum und Uhrzeit kann daher der Fehler auftreten.

hoffe das hilft

gruß
andreas e

http://www.skripteundaufgaben.de

nach oben   nach unten

Re: D5 >= AA1? mit Datum geht nicht
von: Rainer
Geschrieben am: 14.06.2002 - 12:28:37

Lieber Stefan!

Das kann ich nicht nachvollziehen.

Stutzig werde ich aber bei:

...Die Formel =WENN(D5>=AA1;"OK";"NO")liefert mir NO ...,

denn bei mir liefert sie 'OK', was sie ja soll!!!, denn sowohl in D5 als auch in AA1 sollen ja die gleichen Werte (16:30:00) stehen.

Probiere einmal folgendes:
Schreibe in unformatierte!! Zellen =D5 und einmal =AA1 und vergleiche dann die Ergebnisse.

Da ich jetzt weg muss, kann ich dir erst heute Nacht oder morgen wieder antworten. Bei bedarf kannst du mir ja die Tabelle mailen.

Lieben Gruß
Rainer

Lieben Gruß
Rainer

nach oben   nach unten

Re: D5 >= AA1? mit Datum geht nicht
von: Stefan
Geschrieben am: 17.06.2002 - 13:13:52

Hallo Andreas,

jetzt wird es verrückt. Das Excel-Sheet hat die Aufgabe Zeiten zu erfassen (der Excel-Klassiker). Auf der vertikalen sind die Tage und die Kommt Geht Zeiten erfasst und auf der horizontalen als Spaltenüberschrift Tageszeiten von 7:00 bis 19:00 in halb-Stunden-Abständen. Ich vergleiche die Kommt-Geht Zeit mit der Spaltenüberschrift. Dort wo die Kommt-Geht-Zeit >= der >Spaltenüberschrift ist, erzeuge ich per bedingter Formatierung eine Balkendarstellung. Beispiel: =WENN(UND(Kommt<=AA$1;Geht>=AA$1);"*";""). Wobei AA$1 den Vergleichswert enthält. Konkreter Fall: Kommt = 9:00 Uhr; Geht = 16:30; AA$1 16:30. 16:30 wird im Sinne des Vergleichs nicht erkannt; also kein "*"; 16:31 schon. Mache ich den Vergleich mit Z$1 = 16:30 geht alles klar.

Soweit die endlose Vorrede. Ich habe Deinen Vorschlag probiert AA$1 = 00.01.1900 16:30:00 und Geht = 00.01.1900 16:30:00. Es klappt! Ich drehe AA$1 und Geht zurück auf 16:30; geht es weiterhin. Wohlgemerkt ich habe den Test nur mit den beiden o.g. Zellen gemacht und trotzdem funktionieren jetzt alle Vergleiche des Sheets die due o.g. Problematik hatten.

Ich sollte froh sein eine Lösung zu haben aber das warum geht mir nicht aus dem Kopf. Trotzdem Danke Andreas

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "SVERWEIS"