Microsoft Excel

Herbers Excel/VBA-Archiv

Datum wird falsch ermittelt | Herbers Excel-Forum


Betrifft: Datum wird falsch ermittelt von: reiner
Geschrieben am: 07.08.2012 11:15:38

Hallo Leute

https://www.herber.de/bbs/user/81313.xlsx

B1 ist das Tagesdatum; D1 ist ein willkürlich gewähltes Datum.
E1 enthält das Datum aus B1 oder D1 je nachdem welche Optionsschaltfläche betätigt wurde.
Enthält D1 kein Datum (Wert gleich "0") und wird Optionsschaltfläche B1 betätigt, soll in E1 das Datum aus B1 angezeigt werden, tatsächlich steht dort aber nicht der Wert aus B1 sondern 00.01.1900. Der Wert aus E1 dient als Ausgangsbasis für den Kalender im Zellbereich A5 bis A38.
Der Kalender wird benötigt für die Datenüberprüfung in C5.

Warum wird mir das Datum aus B1 nicht angezeigt, was mache ich falsch?

mfg
reiner

  

Betrifft: AW: Datum wird falsch ermittelt von: Dominik
Geschrieben am: 07.08.2012 11:34:38

Hallo Reiner

Das Problem liegt in der Reihenfolge deiner Wennformel in E1 begraben die Wenn-Und Bedingung kann nie Wahr sein.

Erst Wenn-Und abgefragt und schon klappt es.

=WENN($A$1=1;$B$1;WENN(UND($A$1=2;$D$1=0);$B$1;WENN($A$1=2;$D$1;"")))

Gruss Dominik


  

Betrifft: AW: Datum wird falsch ermittelt von: reiner
Geschrieben am: 07.08.2012 11:39:50

hallo Dominik,

du hast vollkommen recht es liegt nur an der Reihenfolge.
Durch weiteres Überprüfen bin ich nahezu zeitgleich mit dir selber auf die Lösung gestoßen,
dennoch vielen Dank für deinen Beitrag.

reiner


  

Betrifft: Datum wird richtig ermittelt von: Erich G.
Geschrieben am: 07.08.2012 13:17:42

Hi Reiner,
hier noch mal in E2 bis E6 gesammelt einige Möglichkeiten:

 ABCDE
1207.08.2012  00.01.1900
2    07.08.2012
3    07.08.2012
4    07.08.2012
500.01.1900   07.08.2012
601.01.1900   07.08.2012

Formeln der Tabelle
ZelleFormel
E1=WENN(A$1=1;B$1;WENN(A$1=2;D$1;WENN(UND(A$1=2;D1=0); B$1;"")))
E2=WENN(A$1=1;B$1;WENN(A$1=2;WENN(D$1=0;B$1;D$1); ""))
E3=WENN(A$1=1;B$1;WENN(UND(A$1=2;D$1=0); B$1;WENN(A$1=2;D$1;"")))
E4=WENN(A$1=1;B$1;WENN(D$1=0;B$1;D$1))
E5=WENN((A$1=2)*(D$1>0); D$1;B$1)
E6=((A$1=1)+(D$1=0)>0)*B$1+((A$1=2)*(D$1>0))*D1

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: Datum wird richtig ermittelt von: reiner
Geschrieben am: 07.08.2012 14:07:38

danke Erich,

am besten gefällt mir die Variante in Zeile 5, diese Formel ist sehr übersichtlich

mfg
reiner


Beiträge aus den Excel-Beispielen zum Thema "Datum wird falsch ermittelt"