Vergleich von Zeiten



Excel-Version: Alle Versionen
nach unten

Betrifft: Vergleich von Zeiten
von: Christian
Geschrieben am: 01.07.2002 - 11:19:06

Hallo,

irgendwie bekomme ich es nicht hin....
ich möchte die Differenz zweier Zeiten mit einer festen Stundenanzahl vergleichen, also
A1 = 8:00
B1 = 12:00
C1 = 3:00 (feste Stundenanzahl)

=wenn( (b1-b2) < c1 ; 0:15 ; 0:45)

aber es kommt nix vernünftiges dabei raus. Die Zellen haben alle das Datumsformat. Was mache ich falsch??

Danke für einen Tip!!

nach oben   nach unten

Re: Vergleich von Zeiten
von: ajk
Geschrieben am: 01.07.2002 - 11:27:47

Hallo,

Ersetze in Deiner Formel mal b2 durch a1! und schreibe die beiden Zeiten 0:15;0:45 in "0:15";"0:45". Dann sollte es besser aussehen!

Gruß
AJK

nach oben   nach unten

habe die Formel falsch geschrieben, richtig ist:
von: Christian
Geschrieben am: 01.07.2002 - 11:46:44

sorry, habe die Formel falsch GEschrieben und das Problem falsch UMschrieben
Wenn man es so schreibt wie von Dir vorgeschlagen geht es, Danke.
Aber es sollte laute:
A1 = 8:00
b1= 12:00

= Wenn ( (b1 - a1)< "3:00"; "0:15" ; "0:45" )


also die Vergleichszeit ("3:00") sollte IM Vergleich stehen. Und dann gehts nicht.




nach oben   nach unten

Zeitberechnung in Excel
von: Michael Wendeler
Geschrieben am: 01.07.2002 - 12:24:47

Hallo,

die Formel muß wie folgt ausschauen:

= Wenn ( (b1 - a1)< (3/24); 0,15/24; 0,45/24)

Da Uhrzeiten als Teil eins Tages dargestellt werden, mußt Du einfach die Stundenanzahl durch 24 teilen (eine Stunde = 24ster Teil eines Tages).

In deinem Fall wird das Ergebnis aus 12:00 - 8:00 zwar als 4:00 dargestellt, aber die Zahl dahinter ist 0,16667 (4/24). Daher kannst Du auch nicht 3:00 in einer Formel nutzen, sondern nur 0,125 oder besser 3/24.

Gruß
M. Wendeler
http://www.wendelers.de



nach oben   nach unten

Re: habe die Formel falsch geschrieben, richtig ist:
von: Birgit
Geschrieben am: 01.07.2002 - 12:35:42

Hi,
das liegt daran, dass die in Anführungsstriche gesetzte Werte für Excel als Text gelten. Also geht nur
=WENN(B1-A1Durch die Zeit-Funktion =Zeit(Stunde;Minute;Sekunde) wird eine bestimmte Zeit in eine Zahl umgewandelt.
Auch mit den Ergebnissen dieser Funktion kannst Du keine weiterberechnungen durchführen, da die Ergebnisse für Excel Text sind.
Gruß, Birgit
 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Vergleich von Zeiten"