Microsoft Excel

Herbers Excel/VBA-Archiv

wenn grösser als und kleiner als dann

Betrifft: wenn grösser als und kleiner als dann von: Bastian Eberl
Geschrieben am: 08.08.2008 13:45:40

Hallo zusammen,


  • ich habe eine spalte mit zahlen.
    diese sollen gruppiert werden.
    dafür soll hinter jede zahl ein A oder B oder C oder D oder E stehen.

    Ich habe das jetzt über diese Formel gelöst.

    
    =WENN(UND(A1>=C5;A1=C4;A1=C3;A1=C2;A1=C1;B1;"fehler"))))) 



    Geht das auch einfacher?

    Grüsse
    Bastian

      

    Betrifft: AW: wenn grösser als und kleiner als dann von: Peter R
    Geschrieben am: 08.08.2008 13:56:13

    Hallöchen,

    kannst Du mal ein Beispiel nennen?
    Aus Deiner Formel wird man nicht wirklich schlau, weil Du den wWert "Fehler" und auch die Zelle B1 mit in die Und Kalmmer genommen hast.

    Gruß

    Peter


      

    Betrifft: AW: wenn grösser als und kleiner als dann von: Bastian Eberl
    Geschrieben am: 08.08.2008 14:42:12




      

    Betrifft: AW: wenn grösser als und kleiner als dann von: David
    Geschrieben am: 08.08.2008 14:51:35

    Das ist nicht wirklich besser. Es gibt anscheinend immer noch kein DANN/SONST in der WENN-Formel, ich vermute mal stark, dass das ab ;B1 sein soll (dann stimmen aber die Klammern nicht) und welche (Art) Werte in den Zellen stehen, wissen wir auch noch nicht.

    Gruß

    David


      

    Betrifft: AW: wenn grösser als und kleiner als dann von: David
    Geschrieben am: 08.08.2008 14:25:11

    Die Formel ergibt keinen Sinn, weil nur eine WENN-Bedingung da ist, aber kein DANN/SONST. Außerdem müsste man schon wissen, welche Werte in den abgefragten Zellen stehen (könnten).

    Gruß

    David


      

    Betrifft: AW: wenn grösser als und kleiner als dann von: Peter R
    Geschrieben am: 08.08.2008 16:15:20

    Hallöchen,

    lad doch einfach mal ne Beispieldatei hoch, und dann erklär nochmal genau was Du möchtest. Denn momentan gleichst Du die Zelle A1 einzeln mit allen Zellen in Spalte C einzeln ab. Soll das ganze nur hinter A1 stehen, oder auch hinter den anderen Zellen (A2 usw.)? Soll überprüft werden, ob der Wert in Zelle A1 irgendwo in Spalte C zu finden ist? Man kann Deinen Ausführungen und der obigen Formel (wie gesagt, ist sowieso fehlerhaft) nicht ganz folgen.

    Gruß

    Peter