Microsoft Excel

Herbers Excel/VBA-Archiv

Zahl auf benutzerdefinierte Spannen runden

Betrifft: Zahl auf benutzerdefinierte Spannen runden von: Tanja
Geschrieben am: 03.12.2015 07:30:54

Hallo,

ich habe eine Tabelle, in der eine Stückzahl als beliebige, ganzzahlige Zahl eingegeben wird.
Anschließend soll diese Zahl durch Abrunden einer bestimmten, benutzerdefinierten Spanne zugeordnet werden.

Problem dabei:
Die Abstände zwischen den einzelnen Spannen sind nicht konstant, so dass ich mit normalem Runden hier nicht weiterkomme.

Beispiele:

- Menge: 2500 = Spanne: 2000
- Menge: 7500 = Spanne: 5000

Mein einziger Ansatz bisher ist eine Verknüpfung von If-Formeln, was jedoch bei vielen Spannen sehr umständlich und unübersichtlich ist.

Hier eine Beispiel-Datei mit dem Eingabefeld in A1 und dem Ausgabefeld in C1:

https://www.herber.de/bbs/user/101981.xlsx

Kann mir jemand eine einfachere / bessere Lösung dafür sagen - v.a. im Hinblick auf eine größere Anzahl von Spannen (ca. 20) ?

Vielen Dank im Voraus.

LG,
Tanja

  

Betrifft: AW:mit Index von: hary
Geschrieben am: 03.12.2015 07:42:28

Moin
=INDEX(D1:L1;1;VERGLEICH(A1;D1:L1;1))
gruss hary


  

Betrifft: AW: AW:mit Index von: Tanja
Geschrieben am: 03.12.2015 08:06:16

Hallo Hary,

vielen Dank dafür !

Das scheint größtenteils zu funktionieren, ich erhalte jedoch "N/A" als Ergebnis, wenn der Eingabewert kleiner als die kleinste Spanne ist, z.B. 100.

Wie würdest Du das umgehen ?

LG,
Tanja


  

Betrifft: AW: AW:mit Index von: hary
Geschrieben am: 03.12.2015 08:30:40

Moin
=WENNFEHLER(INDEX(D1:L1;1;VERGLEICH(A1;D1:L1;1));"Hier was du willst")
gruss hary


  

Betrifft: AW: AW:mit Index von: Tanja
Geschrieben am: 03.12.2015 09:35:15

Super, dass klappt bestens - vielen Dank für die schnelle Hilfe !

LG,
Tanja


 

Beiträge aus den Excel-Beispielen zum Thema "Zahl auf benutzerdefinierte Spannen runden"