Einzelwerte zusammenfügen und summieren

Bild

Betrifft: Einzelwerte zusammenfügen und summieren
von: Peter Weber
Geschrieben am: 29.07.2015 23:09:29

Hallo Zusammen,
ich bitte um Eure Hilfe.
In der Tabelle "Einzeleingaben" habe ich z.B. Postleitzahlen. Nun sollen Euros gleicher Postleitzahlen summiert werden und in die Tabelle "Gruppen" eingefügt werden.
Wie müsste das Makro dazu aussehen?
https://www.herber.de/bbs/user/99159.xlsx
Vielen Dank für Eure Antworten,
Peter

Bild

Betrifft: AW: Einzelwerte zusammenfügen und summieren
von: Sepp
Geschrieben am: 29.07.2015 23:22:08
Hallo Peter,
und warum VBA?
Gruppen

 ABCDE
3     
4 plzName 
5 111Anton50 
6 444Frank125 
7 222Berta500 
8 333Hans100 
9     

Formeln der Tabelle
ZelleFormel
D5=SUMMEWENN(Einzeleingaben!$B$5:$B$11;B5;Einzeleingaben!$D$5:$D$11)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Sepp


Bild

Betrifft: AW: Einzelwerte zusammenfügen und summieren
von: Peter Weber
Geschrieben am: 30.07.2015 13:00:37
Hallo Sepp,
vielen Dank für deine Antwort. Du hast recht. Warum VBA, wenn eine Formel es auch tut.
Leider habe ich mein Problem zu stark vereinfacht.
Meine Datei sieht eher so aus:
https://www.herber.de/bbs/user/99180.xlsx
Ich möchte gern Gruppen über die Namen erstellen und die Euros aufsummieren.
Leider weiß ich nicht wie das Makro dazu aussehen könnte.
Daher bitte ich Euch noch einmal um Hilfe.
LG, Peter

Bild

Betrifft: AW: Einzelwerte zusammenfügen und summieren
von: Michael
Geschrieben am: 01.08.2015 18:47:36
Hi zusammen,
spiel doch mal ein bißchen mit Daten-Teilergebnisse.
Das läßt sich denn auch ganz gut mit dem Makro-Rekorder aufzeichnen.
Schöne Grüße,
Michael

Bild

Betrifft: AW: Einzelwerte zusammenfügen und summieren
von: Peter Weber
Geschrieben am: 03.08.2015 21:17:16
Hallo Zusammen,
kann jemand ein kleines Makro dazu schreiben.
Das wäre eine große Hilfe für mich.
Ich habe mehrere hunderte von Zeilen die ich auf diese Weise bearbeiten möchte.
So wie ich es zur Zeit verstehe müsste das Problem mit mehreren Schleifen, die irgendwie verschachtelt sind gelöst werden. Leider komme ich mit meinem bescheidenen VBA-Kenntnissen nicht weiter.
LG,
Peter

Bild

Betrifft: AW: Einzelwerte zusammenfügen und summieren
von: Sepp
Geschrieben am: 03.08.2015 21:25:10
Hallo Peter,
deine Angaben sind immer noch Mangelhaft! Und immer ncoh sehe ich keinen Grund für VBA.
Gruppen

 ABCDE
3     
4 plzName 
5 111Anton50 
6 222Berta300 
7 444Frank75 
8 333Hans500 
9 999Hans600 
10     

Formeln der Tabelle
ZelleFormel
D5=SUMMENPRODUKT((Einzeleingaben!$B$5:$B$18=B5)*(ISTZAHL(VERGLEICH(C5&"*";Einzeleingaben!$C$5:$C$18;0)))*Einzeleingaben!$D$5:$D$18)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Du solltest aber gleich von Beginn an beschreiben, was du eigentlich erreichen willst!
Gruß Sepp


Bild

Betrifft: Teilergebnisse?
von: Michael
Geschrieben am: 04.08.2015 19:39:09
Hi zusammen,
hast Du, Peter, die Teilergebnisse mal getestet?
Datei anbei: https://www.herber.de/bbs/user/99331.xlsx
Schöne Grüße,
Michael

Bild

Betrifft: AW: Einzelwerte zusammenfügen und summieren
von: Peter Weber
Geschrieben am: 04.08.2015 19:44:47
Hallo Sepp,
danke für deine Antwort.
Das Problem ist, dass ich nur eine Riesentabelle mit Einzeleingaben habe. Die Tabelle "Gruppen" exitiert nicht. Sie soll per VBA-erzeugt werden. In dieser neuen Tabelle sollen gleiche Namen(wie z.B. Berta A, Berta B, Berta C)zu einer Gruppe "Berta" zusammengefasst und die Euro-Daten aufsummiert werden.
Die Namen wie z.B. Anton sollen mit in die Liste aufgenommen werden.
Ich hoffe ich konnte Jetzt mein Problem besser darstellen.
LG und vielen Dank für deine bisherige Bereitschaft zu helfen.
Peter

Bild

Betrifft: AW: Einzelwerte zusammenfügen und summieren
von: Sepp
Geschrieben am: 04.08.2015 19:52:18
Hallo Peter,
dann solltest du mal eine "richtige" Beispieltabelle hochladen.
Woran sollen die Gruppen festgemacht werden?
Steht immer ein Leerzeichen zwischen den Gruppennamen?
Was soll mit den PLZ geschehen? Wie soll danach unterschieden werden?
???

Gruß Sepp


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Einzelwerte zusammenfügen und summieren"