Microsoft Excel

Herbers Excel/VBA-Archiv

Hyperlinks per Formel mitkopieren


Betrifft: Hyperlinks per Formel mitkopieren
von: bbcn
Geschrieben am: 18.12.2018 11:45:12

Hallo,

ich habe folgendes Problem:

Mein Ziel ist es in einer Spalte untereinander gelistete Zellen per Formel so zu kopieren, dass die leeren Zeilen, welche in unregelmäßigen Abständen vorhanden sind, verschwinden. Aus einer Spalte mit sowohl gefüllten, als auch Leerzeilen soll also eine durchgängige Spalte, mit durchgängig gefüllten Zellen entstehen entstehen.

Um dieses Problem zu lösen nutzte ich folgende Formel:

=WENN(ZEILE(A1)>ANZAHL2(A:A);"";INDEX(A:A;KKLEINSTE(WENN(A$1:A$10000<>"";ZEILE($1:$10000)); ZEILE(A1) )))

Diese Formel löst das Problem sehr gut. Leider kopiert es aber nicht die Hyperlinks mit, sondern nur den reinen Zellinhalt. Da es sich um eine große Datenmenge handelt muss ich es irgendwie mit einer Formel lösen. Der manuelle Weg wäre zeitlich nicht machbar.

Hat ein Experte hierfür eine Lösung für mich?

Gruß
Bbcn

  

Betrifft: AW: Hyperlinks per Formel mitkopieren
von: Rudi Maintaire
Geschrieben am: 18.12.2018 12:41:45

Hallo,
warum löschst du nicht einfach die leeren Zeilen?

Spalte markieren; F5; Inhalte; Leerzellen; OK
STRG+ -; ganze Zeile

Gruß
Rudi


  

Betrifft: AW: Hyperlinks per Formel mitkopieren
von: bbcn
Geschrieben am: 19.12.2018 07:37:06

Hallo Rudi,

danke für den Tipp. Die Sache ist, dass ich nun im zweiten Schritt mit der Formel nur jede x´te Zeile rauskopiere. Dies mache ich mit folgender Formel:

=INDEX(B:B;ZEILE()*2)

Nur leider vernachlässigt auch diese Formel den Hyperlink, sodass das Problem wiederkehrt.


  

Betrifft: Crossposting
von: SF
Geschrieben am: 18.12.2018 13:47:38

https://www.clever-excel-forum.de/thread-18497.html