Microsoft Excel

Herbers Excel/VBA-Archiv

Gültigkeitsprüfung: Duplikate in Spalte

Betrifft: Gültigkeitsprüfung: Duplikate in Spalte von: ralph
Geschrieben am: 06.09.2004 11:07:19

Hallo zusammen,

ich probiere schon länger rum - aber mir fällt nichts mehr ein.
Vielleicht kennt jemand von Euch die Lösung.

In eine Spalte werden durch den Benutzer nach und nach Werte eingetragen (alphanumerisch). Nun soll bei der Eingabe eines neuen Wertes geprüft werden, ob sich dieser bereits in der Spalte befindet. Ist dies der Fall, soll eine Meldung erfolgen, die zur Änderung des Wertes auffordert.

Ich vermute, daß dies nur mit der Gültigkeitsprüfung "Formel" gemacht werden kann.
Wird dann nicht der neu eingebene Wert als "bereits vorhanden" eingstuft?

Hilfe wäre prima

  


Betrifft: AW: Gültigkeitsprüfung: Duplikate in Spalte von: Daniel
Geschrieben am: 06.09.2004 11:35:13

Hi,
einfach über Daten Gültigkeit Benutzerdefiniert folgende Formel eingeben:
=VERGLEICH(A1;$A:$A;0)=ZEILE(A1)

Dann die Zelle "herunterziehen".

Ggf. noch in der Gültigkeitsprüfung eine Fehlermeldung eingeben.

mfg Daniel


  


Betrifft: oder ZÄHLENWENN(A:A;A1)=1 ot. von: th.heinrich
Geschrieben am: 06.09.2004 11:42:14




  


Betrifft: AW: oder ZÄHLENWENN(A:A;A1)=1 ot. von: Hannelore
Geschrieben am: 06.09.2004 13:25:19

Dann lässt der Hase das Motorrad an (brumm),
setzt den Helm auf und wünscht sich, dass der Bär schwul ist (megabrumm)...


  


Betrifft: Danke von: ralph
Geschrieben am: 06.09.2004 21:17:51

Danke - Es funktioiert ;-)


  


Betrifft: AW: Danke fuer die rueckmeldung :-) ot. von: th.heinrich
Geschrieben am: 07.09.2004 11:39:28




 

Beiträge aus den Excel-Beispielen zum Thema "Gültigkeitsprüfung: Duplikate in Spalte "