Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Duplikate in mehreren Spalten - die Zweite

Duplikate in mehreren Spalten - die Zweite
05.01.2018 09:28:26
Melitta
... zu meinem Beitrag von eben noch eine andere Frage.
Besteht die Möglichkeit, dass man auch positive und negative Beträge abgleicht? (siehe Anlage)
Ich möchte eigentlich die Zeilen mit einem Vermerk versehen haben, bei denen sich die Daten in Spalte C ausgleichen.
Nochmals liebe Grüße
Melitta
https://www.herber.de/bbs/user/118686.xlsx

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Duplikate in mehreren Spalten - die Zweite
05.01.2018 13:27:23
Melitta
Hat keiner eine Idee? :-(
AW: Duplikate in mehreren Spalten - die Zweite
05.01.2018 14:05:39
fcs
Hallo Melitta,
Ich hab ein wenig getüftelt.
Um es bessernachvollziehen zu können mit und ohne Hilfsspalten.
Die Formeln in Zeile 2 kannst du nach unten kopieren.
Gruß
Franz
Tabelle1

 ABCDEFGH
1Kri 1Kri2Kri3 ZählerAnzahl-StornoErgebnisFormel ohne Hilfsspalten
2Frankniegisch15 10--
3HelmutSchachner20Eingang11Duplikat-AusgleichDuplikat-Ausgleich
4Eberhhadn96 10--
5HelmutSchachner-20Storno12Duplikat-AusgleichDuplikat-Ausgleich
6valentMeier50 10--
7valentMeyer50 10--
8hartbark36 10--
9HelmutSchachner20Eingang21--
10VN01NN0133Eingang11Duplikat-AusgleichDuplikat-Ausgleich
11VN01NN01-33Storno11Duplikat-AusgleichDuplikat-Ausgleich
12HelmutSchachner200Eingang10--

Formeln der Tabelle
ZelleFormel
E2=ZÄHLENWENNS($A$1:A2;A2;$B$1:B2;B2;$C$1:C2;C2)
F2=ZÄHLENWENNS(A:A;A2;B:B;B2;C:C;-C2)
G2=WENN(E2<=F2;"Duplikat-Ausgleich";"-")
H2=WENN(ZÄHLENWENNS($A$1:A2;A2;$B$1:B2;B2;$C$1:C2;C2)<=ZÄHLENWENNS(A:A;A2;B:B;B2;C:C;-C2); "Duplikat-Ausgleich";"-")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Anzeige
AW: Duplikate in mehreren Spalten - die Zweite
05.01.2018 14:10:45
Melitta
Hallo Franz,
hab vielen lieben Dank, das sieht nach einer super Lösung aus! "Leider" habe ich nun Feierabend und kann es erst am Montag austesten. Trotzdem den allerherzlichsten Dank!
Schöne Grüße und ein schönes Wochenende!
Melitta

314 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige