Microsoft Excel

Herbers Excel/VBA-Archiv

vergleichen in mehreren Spalten

Betrifft: vergleichen in mehreren Spalten
von: ChristianG
Geschrieben am: 14.04.2003 - 16:36:38

Hi Leute,

ich möchte zwei Spalten miteinander vergleichen und als Ergebnis die Anzahl der unterschiedlichen Zeilen erhalten.


MS Excel von ChristianG
 ABC
123100A
223200A
32325A
42423A
52520B
625200B
725200B
82623A
93023A
103021A


Es soll gezählt werden, wie oft "A" in Spalte C steht und sich gleichzeitig der Wert in Spalte A nicht wiederholt.
(Ergebnis: 4)....(23A, 24A, 26A und 30A)

Ich glaube, ich habe die entsprechende Formel schon gefunden:
{=SUMME((VERGLEICH(A1:A10&B1:B10;A1:A10&B1:B10;0)=ZEILE(1:10)*(A1:A10=1)*(B1:B10<>""))*1)}
gefunden bei: http://www.excelformeln.de/formeln.html?welcher=334

Leider bekomme ich sie nicht an mein Beispiel angepasst. Hat vielleicht jemand eine Idee? Bin hier am Verzweifeln...

Gruß
Christian

  

=SUMME((VERGLEICH(...))) im Array
von: Boris
Geschrieben am: 14.04.2003 - 17:11:26

Hi Christian,

für die "A´s":

{=SUMME((VERGLEICH(A1:A10&C1:C10;A1:A10&C1:C10;0)=ZEILE(1:10)*(C1:C10="A")*(C1:C10<>""))*1)}

Gruß Boris

  

Und die letzte Bedingung kann weg:
von: Boris
Geschrieben am: 14.04.2003 - 17:13:11

Hi,

{=SUMME((VERGLEICH(A1:A10&C1:C10;A1:A10&C1:C10;0)=ZEILE(1:10)*(C1:C10="A"))*1)}

reicht.
Und übrigens noch als "ganz normale Formel":
=SUMMENPRODUKT((VERGLEICH(A1:A10&C1:C10;A1:A10&C1:C10;0)=ZEILE(1:10)*(C1:C10="A"))*1)

Gruß Boris

  

Re: Und die letzte Bedingung kann weg:
von: ChristianG
Geschrieben am: 14.04.2003 - 17:48:43

Hi Boris,

Danke für die Hilfe.....aber mit der ersten Formel funktioniert es leider immer noch nicht - vielleicht mache ich etwas falsch wenn ich es übersetze? (hab hier leider nur ne englische Excel-Version)

So hab ich´s ausprobiert:
{=SUM((MATCH(A1:A10&C1:C10,A1:A10&C1&C10,0)=ROW(1:10)*(C1:C10="A")*(C1:C10<>""))*1)}
Ergebnis: n/a

Aber die zweite Möglichkeit funktioniert:
=SUMPRODUCT((MATCH(A1:A10&C1:C10,A1:A10&C1:C10,0)=ROW(1:10)*(C1:C10="A"))*1)

...ist auch besser mit einer normalen Formel.

Vielen Dank.

Gruß
Christian

  

Da ist ein & statt einem :
von: Boris
Geschrieben am: 14.04.2003 - 17:58:10

Hi Christian,

{=SUM((MATCH(A1:A10&C1:C10,A1:A10&C1:C10,0)=ROW(1:10)*(C1:C10="A")*(C1:C10<>""))*1)}

Zwischen dem 2. C1:C10 hattest du ein & statt nen :
Vielleicht war´s das.
Aber eine funktionierende Variante hast du ja jetzt.

Gruß Boris

  

Re: Da ist ein & statt einem :
von: ChristianG
Geschrieben am: 15.04.2003 - 15:18:15

Hi Boris,

Das & war natürlich falsch, aber es funktioniert trotzdem nicht mit der Matrix-Formel. Ich hab´s zuhause mit einer deutschen XL-Version probiert, und da lief´s ohne Probleme. Komisch.

Aber die zweite Formel funktioniert und ist auch viel einfacher....danke!

Gruß Christian

 

Beiträge aus den Excel-Beispielen zum Thema "vergleichen in mehreren Spalten"