Herbers Excel-Forum - das Archiv

SVerweis in VBA

Bild

Betrifft: SVerweis in VBA
von: Andreas

Geschrieben am: 10.04.2005 14:43:38
Hallo,
mein SVerweis funktioniert nicht mehr, wenn ich in die Urspungstabelle per Makro neue Daten reinkopiere. Kann man dieses Problem durch eine VBA-Prozedur evtl. beheben?
Gruß, Andi
Bild

Betrifft: ganz bestimmt, aber leider...
von: ransi
Geschrieben am: 10.04.2005 15:13:59
hallo andi
...ist mein Hellseher im Wochende.
Daher kann kann ich auch nicht wissen wie deine ursprungstabelle aussieht.
wie deine datenstruktur ist.
was du für neue daten wohin kopierst.
wie dein makro aussieht.
ransi
Bild

Betrifft: AW: SVerweis
von: Andreas
Geschrieben am: 10.04.2005 15:56:14
=SVERWEIS(Tabelle1!A2;Tabelle3!$A$2:$B$6;2;0)
Wenn in Tabelle 1 neue Daten (Zahlen) reinkopiert werden, fehlt der Formel, wie gesagt, der #BEZUG! in Tab1. Tab3 A sind auch Zahlen, Tab3 B sind Buchstaben
Bild

Betrifft: AW: SVerweis
von: ransi

Geschrieben am: 10.04.2005 19:10:51
hallo andi
normal passt excel die bezüge automatisch an.
versuch mal indirekt zu addressieren.
=SVERWEIS(INDIREKT("Tabelle1!A2");Tabelle3!$A$2:$B$6;2;0)
ransi
 Bild
Excel-Beispiele zum Thema "SVerweis in VBA"
SVERWEIS auf geschlossene Arbeitsmappe aus Makro aufrufen Benutzerdefinierte SVERWEIS-Funktion über mehrere Bereiche
Arbeitszeittabelle und SVERWEIS-Formel Zugriff über SVERWEIS() auf eine Artikelliste
SVERWEIS-Formel über mehrere Fundstellen SVERWEIS-, WVERWEIS- und Matrixformel-Beispiele
SVERWEIS, WVERWEIS, INDEX, VERGLEICH und Zielwertsuche Zweidimensionale Matrix mit der SVERWEIS-Funktion durchsuchen
Hyperlinks zu SVERWEIS-Bezugstabellen anlegen SVERWEIS als Ereignisprozedur