Problem mit WVERWEIS

Bild

Betrifft: Problem mit WVERWEIS
von: Frederic Anders
Geschrieben am: 22.07.2015 13:38:05

Hi Leute,
heute brauch ich mal kurz Eure HIlfe:
Normalerweise machen mir Formeln null aus - nur heute komm ich net weiter, evtl. liegts an der Hitze LOL:
Das ist meine Formel, basierend auf einer Tabelle in der ich mit dem WVEREIS suche, und einen Betrag, der mal positiv sowie auch negativ sein kann:
=WENN(O5<0;WVERWEIS(Firmen!$G$1;Firmen!$G$8:$N$12;4;WVERWEIS(Firmen!$G$1;Firmen!$G$8:$N$12;3)))
In O2 stehen Werte (+120; oder -25)
Wenn POSTIV, soll er in der Range auf Zeile 3 gehen, sonst auf Zeile 4.
Leider bekomme ich bei der 2 Variante immer FALSCH geliefert...
Wo hängts denn noch?
Dank Euch vorab und LG
Frederic

Bild

Betrifft: AW: Problem mit WVERWEIS
von: SF
Geschrieben am: 22.07.2015 13:44:34
Hola,
Excel Profi?
Deine Wenn dann ist ja schon völlig falsch.

=WENN(O5<0;WVERWEIS(Firmen!$G$1;Firmen!$G$8:$N$12;4;0);WVERWEIS(Firmen!$G$1;Firmen!$G$8:$N$12;3;0)) 
Gruß,
steve1da

Bild

Betrifft: AW: Problem mit WVERWEIS
von: Frederic Anders
Geschrieben am: 22.07.2015 13:48:56
Hallo Steve,
dank dir! Ist wohl doch die Hitze :-)
Ja eigentlich schon Profi, sonst mach ich z.B. solche Sachen, aber heute hab ich nix auf die Reihe gekriegt, kein Wunder, ich schmilz dahin LOL
=WENN(WENN(ISTFEHLER(SVERWEIS($L523;GJimport!$B$1:$X$5011;15;FALSCH));0;(SVERWEIS($L523;GJimport!$B$1:$X$5011;15;FALSCH)))<0;0;WENN(ISTFEHLER(SVERWEIS($L523;GJimport!$B$1:$X$5011;15;FALSCH));0;(SVERWEIS($L523;GJimport!$B$1:$X$5011;15;FALSCH))))
LG Frederic

Bild

Betrifft: AW: Problem mit WVERWEIS
von: SF
Geschrieben am: 22.07.2015 13:49:57
Hola,
hat der Sverweis irgendwas mit dem Problem zu tun?
Gruß,
steve1da

Bild

Betrifft: AW: Problem mit WVERWEIS
von: Frederic Anders
Geschrieben am: 22.07.2015 13:51:53
Nicht wirklich :-) wollte Dir nur zeigen , dass ich kein Anfänger bin, habe mit verschachtelten Formeln keine Probleme, aber heut war irgendwie der Wurm drin...
Dank dir nocmals!!!!

Bild

Betrifft: Du hast XL2010 da gibt es WENNFEHLER() owT
von: der neopa C
Geschrieben am: 22.07.2015 13:55:01
Gruß Werner
.. , - ...

Bild

Betrifft: ohne Wenn()
von: Rudi Maintaire
Geschrieben am: 22.07.2015 13:52:36
Hallo,
Hitze ist keine Entschuldigung für grobe Fehler ;-)
=WVERWEIS(Firmen!$G$1;Firmen!$G$8:$N$12;3+(O5<0);)
Gruß
Rudi

Bild

Betrifft: ganz ohne WENN() ...dafür aber 4. Parameter ...
von: der neopa C
Geschrieben am: 22.07.2015 13:53:54
Hallo Frederic,
... so:


=WVERWEIS(Firmen!$G$1;Firmen!$G$8:$N$12;3+(O5<0);0)
Gruß Werner
.. , - ...

Bild

Betrifft: zu langsam! Ätschbätsch ;-)
von: Rudi Maintaire
Geschrieben am: 22.07.2015 13:54:46


Bild

Betrifft: war die 0; die ich sonst nie schreibe ;-) owT
von: der neopa C
Geschrieben am: 22.07.2015 14:00:43
Gruß Werner
.. , - ...

Bild

Betrifft: 1:18 Min für ne 0 ????
von: Rudi Maintaire
Geschrieben am: 22.07.2015 14:02:32


Bild

Betrifft: hab davon jedes einzelne Pixel gemalt ;-) owT
von: der neopa C
Geschrieben am: 22.07.2015 14:21:51
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Problem mit WVERWEIS"