Kombination von S- und WVerweis

Bild

Betrifft: Kombination von S- und WVerweis von: André
Geschrieben am: 07.04.2005 12:16:16

Hallo an alle fleißigen Helfer,

ich habe versucht einen Sverweis mit einem Wverweis zu kombinieren. Sprich; Ich würde gerne in Tabelle 1 in der Spalte A nach einem bestimmten Begriff suchen. Anschließend soll er mir den zugehörigen Wert in Spalte D liefern.
Soweit so gut, jedoch soll er überdies den Wert der eine Zeile tiefer liegt ausgeben. (D.h. gehe von dem gefundenen Wert eine Zelle nach unten)
Die Kombination aus S- und WVerweis klappt nicht, da der Wverweis eine feste Bezugszeile braucht, die ich Ihm nicht geben kann, da die Zeile nicht immer die gleiche ist (klar wird ja auch erst mit dem Sverweis gesucht).
Kann man stattdessen nicht einfach sagen: wenn du den Wert gefunden hast, gehe von dort eine Zelle nach unten (ggf. noch eine nach rechts o.ä.)?

P.S. Leider klappte bei mir auch Bereiche.Verschieben nicht, da der zu verschiebene Bereich Teil einer Formel ist (Zirkelverweis).

Wer weiß RAT???
Vielen Dank für eure geopferte Zeit. [Hoffe Problem wurde treffend umschrieben]

Dank; André [Nono]

Bild


Betrifft: AW: Kombination von S- und WVerweis von: Ramses
Geschrieben am: 07.04.2005 13:06:00

Hallo

warum sollte "Bereich.Verschieben" nicht funktionieren

Tabelle1
 ABCDEF
1SuchbegriffBirne    
2Wert2    
3Ergebnis 122    
4Ergebnis 222a    
5Wert1234 
6Apfel1234 
7 1a2a3a4a 
8Birne11223344 
9 11a22a33a44a 
10Pfirsich111111111111 
11 111a222a333a444a 
12      
Formeln der Tabelle
B3 : =BEREICH.VERSCHIEBEN(A5;VERGLEICH($B$1;$A$6:$A$11;1);WVERWEIS($B$2;$B$5:$E$5;1;0))
B4 : =BEREICH.VERSCHIEBEN(A5;VERGLEICH($B$1;$A$6:$A$11;1)+1;WVERWEIS($B$2;$B$5:$E$5;1;0))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



Ansonsten ist eine Beispieltabelle fällig,... Hellsehen kann hier niemand :-)

Gruss Rainer


Bild


Betrifft: AW: Kombination von S- und WVerweis von: Werner
Geschrieben am: 07.04.2005 13:15:24

Hallo André,

für die Aufgabenstellung kombinierst Du am besten die VERGLEICH- mit der INDEX-Funktion

z.B.

Bereich A10:D20 Tabellenbereich

Zelle A1: Suchbegriff

Zelle A2: =VERGLEICH(A1;A10:a20;0) := Ermittlung der Zeile im Tabellenbereich
Zelle B2: =INDEX(D10:D20;A2;4) := Wert aus der gleichen Zeile
Zelle B3: =INDEX(D10:D20;A2+1;4) := Wert aus der folgenden Zeile

Viel Erfolg.

Werner


Bild


Betrifft: AW: Kombination von S- und WVerweis von: Werner
Geschrieben am: 07.04.2005 13:21:08

Korrektur:

die Index-Funktionen müssen lauten:

Zelle B2: =INDEX(A10:D20;A2;4) := Wert aus der gleichen Zeile
Zelle B3: =INDEX(A10:D20;A2+1;4) := Wert aus der folgenden Zeile

Sorry
Werner


Bild


Betrifft: AW: Kombination von S- und WVerweis von: André
Geschrieben am: 07.04.2005 13:47:46

Hallo @ Ramses und Werner,

ertmal vielen Dank für die schnelle Hilfe. Die Idee von Werner habe ich schon ausprobiert und die funktioniert auch!
@ Ramses: OK... erscheint ein bisserl schwierig, Brauche wohl noch 2-3 Minuten, bis das bei mir klappt.
Habt Dank
LG
André


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Kombination von S- und WVerweis "