Zeitangaben in Dezimalminuten

Bild

Betrifft: Zeitangaben in Dezimalminuten
von: Georg
Geschrieben am: 22.09.2003 11:34:58

Guten Tag zusammen,

ich möchte verschiedene Stundenangaben in Minutenangaben (Dezimal) umrechnen.
Hierzu habe ich bereits folgenden Versuch unternommen, Beispiel:

Zelle A1 ist die Eingabezelle.
Zelle B1 habe ich folgende Formel geschrieben:
"=Stunde(A1)*60+Minute(A1)+Sekunde(A1)/60"
Anschließend muß die Zelle B1 noch als "Standard" formatiert werden.

Soweit so gut. Wenn ich jetzt in der Eingabezelle A1 z.B. 04:30:50 eingebe,
wird korrekt gerechnet. Ich habe aber größere Zeitwerte,
z.B: 32:30:30. Das funktioniert jedoch nicht mehr (geht nur bis 24 Stunden).
Auch das Formatieren der Zelle A1 auf "[h]:mm:ss" bringt kein Abhilfe.

Weiß jemand einen Rat??
Danke
MfG Georg

Bild


Betrifft: AW: Zeitangaben in Dezimalminuten
von: Hajo_Zi
Geschrieben am: 22.09.2003 11:38:25

Hallo Georg

verstehe ich da was falsch. Zu beginn scheibst Du das Du Minuten hanen wills am Ende Formatierung "[h]:mm:ss" warum nicht [mm]:ss ??



Falls Code vorhanden wurde dieser getestet unter Betriebssystem XP Pro und Excel Version XP SBE.
Bitte kein Mail, Probleme sollen im Forum gelöst werden.

Microsoft MVP für Excel

Das Forum lebt auch von den Rückmeldungen.

Zurzeit gibt es wieder Probleme mit der E-Mail Benachrichtigung.

Ich bekomme Mails zu Beiträgen an denen ich nicht beteiligt bin und zusätzlich noch Mails zu meinen eigenen Beiträgen.
Das Problem mit den eigenen Benachrichtigung kann gelöst werden durch Lösche und Neuanmelden. Dieses möchte ich aber nicht jeden Tag machen.
Um dieses Problem erstmal zu beseitigen habe ich die automatische Mailbenachrichtigung abgeschaltet.
Aus diesem Grunde ist es dem Zufall überlassen ob auf Rückfragen Antworten von mir kommen.


http://home.media-n.de/ziplies/



Bild


Betrifft: =Ganzzahl(a1*24*60)
von: Ingo
Geschrieben am: 22.09.2003 11:50:18

Hallo Georg,

die oben angegebene Formel gibt Dir alle vollenen Minuten in a1 zurück.

wenn du ab 30 sek aufgerundete Werte benötigst funzt folgende Formel:

=RUNDEN(A1*24*60;0)

Gruß Ingo


Bild


Betrifft: AW: Nachtrag
von: Georg
Geschrieben am: 22.09.2003 12:12:06

Ich habe nur verschiedene Formate ausprobiert. Die Eingabe in Zelle A1
soll z.B. 52 Stunden, 11 Minuten und 25 Sekunden sein, also: "52:11:30"
In Zelle B1 sollen dann die Minuten mit Dezimalstellen stehen, das wären
hier 3131,5 Minuten.

Übrigens Danke an Ingo. Bei der Ganzzahl-Formel fehlen mir leider noch
die Nachkommastellen.

Sorry wenn ich mich anfangs etwas mißverständlich ausgedrückt habe.

MfG
Georg


Bild


Betrifft: AW: Nachtrag
von: Hajo_Zi
Geschrieben am: 22.09.2003 12:14:54

Hallo Georg

lasse das Wort Ganzzahl weg bei Ingo seinem Vorschlag.



Falls Code vorhanden wurde dieser getestet unter Betriebssystem XP Pro und Excel Version XP SBE.
Bitte kein Mail, Probleme sollen im Forum gelöst werden.

Microsoft MVP für Excel

Das Forum lebt auch von den Rückmeldungen.

http://home.media-n.de/ziplies/



Bild


Betrifft: AW: Nachtrag
von: Ingo
Geschrieben am: 22.09.2003 12:17:00

Hallo Georg,

also:

mit allen nachkommastellen:
=A1*24*60

mit x nachkommastellen:
=RUNDEN($A$1*24*60;x) (für x setzt Du einfach eine Zahl aus N ein)

Gruß ingo


Bild


Betrifft: AW: Danke, es funzt
von: Georg
Geschrieben am: 22.09.2003 12:29:38

Vielen Dank an Ingo und Hajo. Es funktioniert.
(Wie einfach manche Sachen sind, wenn mans weiß)

Also bis denne...

Gruß
Georg


Bild


Betrifft: Danke für die Rückmeldung oT
von: Hajo_Zi
Geschrieben am: 22.09.2003 12:32:06




 Bild

Beiträge aus den Excel-Beispielen zum Thema " Ausblenden Div/0"