SUMME & ZÄHLENWENN

Bild

Betrifft: SUMME & ZÄHLENWENN
von: Marcus Willamowski
Geschrieben am: 26.11.2003 13:59:25

Hallo Forum,

ich habe ein einfaches Problem mit einer Formelkombination. In Spalte A habe ich Textwerte (A, B oder C) und in Spalte B Zahlenbeträge (100, 200 etc.). Ich kann die SUMME der Spalte B bilden und ich kann mit ZÄHLENWENN herausfinden, wie oft in Spalte A der Buchstabe C enthalten ist.

Wie aber muss eine Formel aussehen, die alle Beträge in Spalte B summiert, die in derselben Zeile in Spalte A einen bestimmten Buchstaben (z.B. C) haben?

Es kann doch nicht sein, dass man das über VBA lösen muss...

Danke für Eure Hilfe

Marcus

Bild


Betrifft: AW: SUMME & ZÄHLENWENN
von: geri
Geschrieben am: 26.11.2003 14:04:17

Marcus

zB so

=ZÄHLENWENN(C$3:C65;"x") c3-c65 ist Bereich

gruss geri


Bild


Betrifft: AW: SUMME & ZÄHLENWENN
von: Marcus Willamowski
Geschrieben am: 26.11.2003 14:12:05

Danke geri für die schnelle Antwort,

aber - wenn ich es richtig verstehe - sagt mir Deine Formel wie oft im Bereich c3:c65 der Wert der Zelle "x" ist, oder? Mein Problem geht leider weiter...

Wenn z.B. c3, c9, c27 und c61 = x ist möchte ich die SUMME von (entsprechend) b3, b9, b27 und b61 bilden. Wie mache ich das?


Bild


Betrifft: AW: SUMME & ZÄHLENWENN
von: fx
Geschrieben am: 26.11.2003 14:17:00

2 moeglichkeiten:
- es gibt die funktio zaehlenwenn()
- du machst autofilter, laesst nur alle werte mit x anzeigen und summierst dann auf (filter muss ueber a:b gelegt werden, filtere spalte a und summiere b).


Bild


Betrifft: =SUMMENPRODUKT((A1:A100="C")*B1:B100)
von: Boris
Geschrieben am: 26.11.2003 14:16:11

Grüße Boris


Bild


Betrifft: AW: warum nicht SUMMEWENN(...) ? ot
von: Jorainbo
Geschrieben am: 26.11.2003 18:10:23




Bild


Betrifft: AW: warum nicht SUMMEWENN(...) ? ot
von: Marcus Willamowski
Geschrieben am: 26.11.2003 18:56:35

Richtig, es kann so einfach sein. Sorry für die Betriebsblindheit


Bild

Beiträge aus den Excel-Beispielen zum Thema " Suchen in Spalten"