Microsoft Excel

Herbers Excel/VBA-Archiv

Fehler "#wert!" bei Array formel



Excel-Version: 9.0 (Office 2000)

Betrifft: Fehler "#wert!" bei Array formel
von: Thomas
Geschrieben am: 03.06.2002 - 21:51:11

Hi @all!
ich habe folgende formel aufgestellt:

{=SUMME(($D3:$D46)*(E3:E46))/SUMME(E3:E46)}

in spalte D3:D46 ist folgende Formel hinterlegt:

=WENN(C3=0;"";SUMME(C3*93+1,4)/100)

in der ausgabezelle der Array-Formel steht dann der Fehler #wert! statt dem ergebnis ;o((
leider habe ich keine idee wie ich den fehler abstellen kann und hoffe auf hilfe hier im forum.
danke schonmal im voraus
Gruss
Hasenhirte

  

Re: Fehler "#wert!" bei Array formel
von: Arnim
Geschrieben am: 03.06.2002 - 22:29:40

Hallo Hasenhirte,

Du hast die Formel nicht mit den Tasten "Strg"+"Shift" und "Enter" eingegeben!
Wenn Du damit Schwierigkeiten hast, dann schreibe:
=SUMMENPRODUKT(($D3:$D46)*(E3:E46))/SUMME(E3:E46)
Dies Formel gibst Du normal mit "Enter" ein.

Gruß Arnim

  

Re: Fehler "#wert!" bei Array formel
von: Thomas
Geschrieben am: 03.06.2002 - 22:39:55

Hi Armin!

doch habe sie mit strg+shift+enter eingegeben. wenn ich mich auf spalte c3:c46 beziehe funktioniert es auch einwandfrei. mein verdacht liegt darin dass in der spalte C keine formel hinterlegt ist sondern dort direkt ein wert eingegeben wird der dann ja in spalte D umgerechnet wird. wenn ich die formel von dir benutze kommt leider der gleiche fehler ;o(
Gruss
Hasenhirte

  

Re: Fehler "#wert!" bei Array formel
von: Arnim
Geschrieben am: 04.06.2002 - 08:28:49

Hallo,
wenn Werte statt Formeln eingegeben sind, dürfte es nichts ausmachen es sei denn, die Formeln in den Spalten ergeben schon einen Fehlerwert).
Aber ist irgendwo ein Text in den Spalten?
Bei mir funktioniert Dein Beispiel, es sei denn, ich tippe irgendwo einen Buchstaben ein. Dann ist es ja klar!
Drück doch mal "Strg"+"#" - vielleicht ist irgendwo eine Formel, die nicht hingehört?
Gruß Arnim

  

Re: Fehler "#wert!" bei Array formel
von: Thomas
Geschrieben am: 04.06.2002 - 10:05:04

hi armin!
also ich hab nochmal ein bisschen experimentiert, und es scheint an der WENN-Funktion zu liegen die in spalte D3:D46 hinterlegt ist ( =WENN(C46=0;"";SUMME(C46*93+1,4)/100) ) die wenn WENN-Funktion benötige ich da sonst in der spalte ein wert errechnet wird auch wenn z.B. in spalte C46 kein wert eingetragen worden ist. Leider weiss ich keine andere möglichkeit dies zu umgehen....
Gruss Hasenhirte
  

Re: Fehler "#wert!" bei Array formel
von: Arnim
Geschrieben am: 04.06.2002 - 11:12:53

Hallo Hasenhirte,

jawohl, daran liegt es! Es ist halt immer schwer zu helfen, wenn man die Datei nicht vor sich hat.

Vorschlag:
Ändere die Formel in Spalte D:
=WENN(C3=0;0;SUMME(C3*93+1,4)/100)
Sollten Dir die Nuller nicht gefallen, dann deaktiviere die Nullwerte in Extras-Optionen-Ansicht!

Gruß Arnim

  

Re: Fehler "#wert!" bei Array formel
von: Thomas
Geschrieben am: 04.06.2002 - 11:23:33

Hi Armin!

Danke! das war des Problems Lösung! Perfekt nun läufts ohne schwierigkeiten. Nochmals Danke für die Hilfe, wenn ichs vielleicht auch etwas kompliziert erklärt habe.
Gruss, Hasenhirte


 

Beiträge aus den Excel-Beispielen zum Thema "Fehler "#wert!" bei Array formel"