Array formel mit 2 abfragen (wenn)

Bild

Betrifft: Array formel mit 2 abfragen (wenn)
von: chris b
Geschrieben am: 21.03.2005 11:44:55
Hallo Formelprofis,
ich bin gearde am testen um umbauen einer Array Formel komme aber nicht zu dem was ich will,und hoffe ihr könnt mir helfen.
Habe folgender Array formel
=MITTELWERT(WENN(A4:A11=D1;B4:B11;"nix"))
in dieser möchte ich gerne noch eine Wenn funktion mit einbauen.
Bis jetzt schaut die formel in Excel nach ob in zellen A4 bis A11 der wert "cb" steht,
trifft das zu errechnet es mir dem Mittelwert aus den Zellen B4 bis B11 naben dem cb in spalte A
Was ich jetzt noch gerne möchte ist das es mir noch zusätzlich prüft ob die Werte in Zelle B1 is B11 zahlen sind. Habe mir das also so vorgestellt -- noch zusätzlich eine Wenn(istzahl finktion mit einzubauen.
Stelle mir das etwa so vor
=MITTELWERT(WENN(A4:A11=D1; "wenn(B4:B11) istzahl" ;"nix"))
Ich weiß das das ganze sicher auch noch anders möglich ist aber ich benötige diese Funktion zu lernzwecken für mich.

Vielen Dank Christian !

Bild

Betrifft: AW: Array formel mit 2 abfragen (wenn)
von: c0bRa
Geschrieben am: 21.03.2005 11:54:06
also wenn dich dich richtig verstehe:
{=MITTELWERT(WENN(und(A4:A11=D1;istzahl(A4:A11));B4:B11;"nix"))}
Achtung Matrixformel!!! Umrandende {} nicht mit eingeben, sondern mit Strg+Shift+Enter abschliessen!

Rückmeldung nicht vergessen...
c0bRa
Bild

Betrifft: AW: Array formel mit 2 abfragen (wenn)
von: c0bRa
Geschrieben am: 21.03.2005 11:55:32
sorry...
{=MITTELWERT(WENN(UND(A4:A11=D1;ISTZAHL(b4:b11));B4:B11;"nix"))}
natürlich ;)
Bild

Betrifft: AW: Array formel mit 2 abfragen (wenn)
von: HermannZ
Geschrieben am: 21.03.2005 11:55:10
Hallo Christian,
ohne den Sinn jetzt zu verstehen eine möglichkeit;
Beispiel;
Test
 ABCD
1   2
2    
3    
422  
52wert8,8 
626  
728  
82zu  
9212  
102dem  
11216  
12    
13    
Formeln der Tabelle
C5 : {=MITTELWERT(WENN(A4:A11=D1;WENN(ISTZAHL(B4:B11);B4:B11;"nix")))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Gruß hermann
Bild

Betrifft: AW: Array formel mit 2 abfragen (wenn)
von: chris b
Geschrieben am: 21.03.2005 12:05:02
Vielen Dank euch beiden hat mir gut geholfen !
Bild

Betrifft: weiter geht´s ;-))
von: heikoS
Geschrieben am: 21.03.2005 12:03:10
Hallo Christian,
hier also die Fortsetzung:
=MITTELWERT(WENN(A4:A11=D1;WENN(ISTZAHL(B4:B11);B4:B11;"nix")))
Wenn Du auch die 0 ausschließen möchtest (Deine nächste Frage ;-)):
=MITTELWERT(WENN(A4:A11=D1;WENN(B4:B11<>0;B4:B11;"nix")))
Die übrigen Anpassungen von neulich kannst so mit einbauen.

Gruß Heiko
Bild

Betrifft: AW: weiter geht´s ;-))
von: chris b
Geschrieben am: 21.03.2005 13:14:37
Danke euch Dir heiko :o)
Bild

Betrifft: AW: {=MITTELWERT(WENN(A4:A11=D1;B4:B11))}
von: FP
Geschrieben am: 22.03.2005 00:02:24
Hallo Christian,
tut's dann aber auch ;-)

Servus aus dem Salzkammergut
Franz
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Array formel mit 2 abfragen (wenn)"