Berechnung der Wochentage

Bild

Betrifft: Berechnung der Wochentage von: Thomas
Geschrieben am: 06.02.2005 18:23:25

Hallo Zusammen!
Stehe vor einem Problem!
Wie kann ich mir anzeigen lassen, wieviele Montage, Dienstage,usw. in diesen Zeitäumen liegen?

01.01.2005 10.01.2005
15.01.2005 13.01.2005
02.01.2005 03.01.2005

Vielen Dank.
Thomas

Bild


Betrifft: AW: Berechnung der Wochentage von: Hübi
Geschrieben am: 06.02.2005 18:30:16

Hi Thomas,

nur mal als Denkanstoß: Jeder Wochentag wiederholt sich nach jeweils 7 Tagen immer wieder.
Bei Excel gut (und wenig Mathe) fällt dir die Lösung schon ein ;-)))

Gruß Hübi


Bild


Betrifft: AW: Berechnung der Wochentage von: FP
Geschrieben am: 06.02.2005 18:51:40

Hi Thomas,

das geht so:

15.1. bis 13.1. wird dabei als 13.1. bis 15.1. interpretiert: ;-)

Tabelle1
 ABCDEFGHI
1  MoDiMiDoFrSaSo
201.01.200510.01.20052111122
302.01.200503.01.20051000001
415.01.200513.01.20050001110
Formeln der Tabelle
C2 : {=SUMME(N(TEXT(ZEILE(INDIREKT($A2&":"&$B2));"TTT")=C$1))}
D2 : {=SUMME(N(TEXT(ZEILE(INDIREKT($A2&":"&$B2));"TTT")=D$1))}
E2 : {=SUMME(N(TEXT(ZEILE(INDIREKT($A2&":"&$B2));"TTT")=E$1))}
F2 : {=SUMME(N(TEXT(ZEILE(INDIREKT($A2&":"&$B2));"TTT")=F$1))}
G2 : {=SUMME(N(TEXT(ZEILE(INDIREKT($A2&":"&$B2));"TTT")=G$1))}
H2 : {=SUMME(N(TEXT(ZEILE(INDIREKT($A2&":"&$B2));"TTT")=H$1))}
I2 : {=SUMME(N(TEXT(ZEILE(INDIREKT($A2&":"&$B2));"TTT")=I$1))}
C3 : {=SUMME(N(TEXT(ZEILE(INDIREKT($A3&":"&$B3));"TTT")=C$1))}
D3 : {=SUMME(N(TEXT(ZEILE(INDIREKT($A3&":"&$B3));"TTT")=D$1))}
E3 : {=SUMME(N(TEXT(ZEILE(INDIREKT($A3&":"&$B3));"TTT")=E$1))}
F3 : {=SUMME(N(TEXT(ZEILE(INDIREKT($A3&":"&$B3));"TTT")=F$1))}
G3 : {=SUMME(N(TEXT(ZEILE(INDIREKT($A3&":"&$B3));"TTT")=G$1))}
H3 : {=SUMME(N(TEXT(ZEILE(INDIREKT($A3&":"&$B3));"TTT")=H$1))}
I3 : {=SUMME(N(TEXT(ZEILE(INDIREKT($A3&":"&$B3));"TTT")=I$1))}
C4 : {=SUMME(N(TEXT(ZEILE(INDIREKT($A4&":"&$B4));"TTT")=C$1))}
D4 : {=SUMME(N(TEXT(ZEILE(INDIREKT($A4&":"&$B4));"TTT")=D$1))}
E4 : {=SUMME(N(TEXT(ZEILE(INDIREKT($A4&":"&$B4));"TTT")=E$1))}
F4 : {=SUMME(N(TEXT(ZEILE(INDIREKT($A4&":"&$B4));"TTT")=F$1))}
G4 : {=SUMME(N(TEXT(ZEILE(INDIREKT($A4&":"&$B4));"TTT")=G$1))}
H4 : {=SUMME(N(TEXT(ZEILE(INDIREKT($A4&":"&$B4));"TTT")=H$1))}
I4 : {=SUMME(N(TEXT(ZEILE(INDIREKT($A4&":"&$B4));"TTT")=I$1))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Servus aus dem Salzkammergut
Franz


Bild


Betrifft: AW: Berechnung der Wochentage von: Lou38
Geschrieben am: 06.02.2005 23:27:37

Hallo Thomas

Hier noch ein Lösungsvorschlag:

Zelle a1: Anfangsdatum (TT.MM.JJ)
Zelle a2: Enddatum
Zelle a3: {=SUMME((WOCHENTAG(ZEILE(INDIREKT(A$1&":"&A$2));2)=ZEILEN($3:3))*1)}
Zellen a4 bis a9: Formel von Zelle a3 runterkopieren

Die geschweiften Klammern in den Formeln der Zellen a3 bis a9 sind - pro Zelle d. h. 7 Mal - wie folgt einzugeben:
- Cursor irgendwo auf Formel im Formeleditor setzen
- Strg / Umschalttaste / Eingabetaste drücken

Zelle b3: Montag (Texteingabe)
Zelle b4: Dienstag
etc. bis
Zelle b9: Sonntag

Gruss
Louis


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Berechnung der Wochentage"