Microsoft Excel

Herbers Excel/VBA-Archiv

min in hh:mm

Betrifft: min in hh:mm von: Snewi
Geschrieben am: 23.11.2012 10:04:41

Guten Morgen,

ich habe eine Zahl 59,4min und möchte diese gerne in 00:59 anzeigen!
Wenn die Zahl 220min ist dann 03:40!

Wie löse ich das?

Gruß

  

Betrifft: Zahl/1440 & Format h:mm owT von: Rudi Maintaire
Geschrieben am: 23.11.2012 10:22:04




  

Betrifft: AW: Zahl/1440 & Format h:mm owT von: Snewi
Geschrieben am: 23.11.2012 10:57:07

Danke!!


  

Betrifft: falls es einmal ein paar min mehr sein sollte von: mäxl
Geschrieben am: 23.11.2012 10:28:21

Hi,

=deine_Zahl/1440
Format der Zelle benutzdef.
[hh]:mm

gruß


  

Betrifft: AW: falls es einmal ein paar min mehr sein sollte von: Snewi
Geschrieben am: 23.11.2012 12:47:56

Klappt auch soweit! Wie kann ich hier Minuszeiten trotzdem anzeigen so dass keine Rauten angezeigt werden?

Gruß


  

Betrifft: AW: falls es einmal ein paar min mehr sein sollte von: Rudi Maintaire
Geschrieben am: 23.11.2012 13:00:47

Hallo,
siehe hier: http://www.online-excel.de/excel/singsel.php?f=25

Gruß
Rudi


  

Betrifft: AW: falls es einmal ein paar min mehr sein sollte von: Snewi
Geschrieben am: 23.11.2012 13:25:40

Ich rechne leider nicht direkt in Excel sondern bekomme den negativ Wert schon aus der Datenbank!
Hier habe ich dann einen SVERweis:

=WENN(S20
Klappt aber nicht :-(


  

Betrifft: AW: falls es einmal ein paar min mehr sein sollte von: Snewi
Geschrieben am: 23.11.2012 13:35:45

Ich rechne leider nicht direkt in Excel sondern bekomme den negativ Wert schon aus der Datenbank!
Hier habe ich dann einen SVERweis:

SVERWEIS($C20;STW_Zeiten!$C:$AT;Q$9;0)

Kann die ganze Formel aus dem Link hier nicht reinkopieren, weil das posting dann falsch angezigt wird ;-(

Wie müsste meine Formel aussehen damit auch die - Werte angezeigt werden?

Gruß
Gruß


  

Betrifft: was soll mir das sagen? von: Rudi Maintaire
Geschrieben am: 23.11.2012 14:15:09

Hallo,
ist das die Formel, die die Minuten liefert?
=Wenn(SVERWEIS($C20;STW_Zeiten!$C:$AT;Q$9;0)<0;"-";"") &text(abs(SVERWEIS($C20;STW_Zeiten!$C:$AT; Q$9;0));"hh:mm")

Gruß
Rudi


  

Betrifft: AW: was soll mir das sagen? von: Snewi
Geschrieben am: 26.11.2012 08:45:54

Ja das klappt soweit nur die bedingte Formatierung, bei der ich prüfe ob ein Wert größer 7min ist funktioniert nicht mehr!

gruß


  

Betrifft: AW: was soll mir das sagen? von: Snewi
Geschrieben am: 26.11.2012 08:51:56

So klappt es :

=WENN(SVERWEIS($C19;STW_Zeiten!$C:$AT;Q$9;0)/1440<0;"-"&TEXT(ABS(SVERWEIS($C19;STW_Zeiten!$C:$ _
AT;Q$9;0));"hh:mm");SVERWEIS($C19;STW_Zeiten!$C:$AT;Q$9;0)/1440)
Danke und Gruß


  

Betrifft: AW: was soll mir das sagen? von: Snewi
Geschrieben am: 26.11.2012 08:59:45

Jetzt müsste ich nur noch wissen wie ich dieses Textformat in rot formatiert bekomme ?? :-)


  

Betrifft: AW: was soll mir das sagen? von: Snewi
Geschrieben am: 26.11.2012 09:07:59

Habs jetzt hierüber gemacht:

=SUCHEN("Text";A1)
Nur hab noch ne andere bedingte Formatierung die auch immer zuschlägt! Hier überprüfe ich nur ob die Zahl größer 7min ist ! Warum?

Gruß


  

Betrifft: 4 Antworten auf eine Frage-warum????? owT von: robert
Geschrieben am: 26.11.2012 11:41:17




  

Betrifft: Er führt öffentl Selbstgespräche! ;->> Gruß owT von: Luc:-?
Geschrieben am: 26.11.2012 13:11:10

:-?


  

Betrifft: AW: Er führt öffentl Selbstgespräche! ;->> Gruß owT von: Snewi
Geschrieben am: 26.11.2012 15:11:43

Ich wollte euch nur zeigen wie schwer es machnchmal mit mir ist :-)

Gruß


  

Betrifft: Det wissn wa! :-] ~owT~ von: Luc:-?
Geschrieben am: 27.11.2012 13:23:15

:-?