Herbers Excel-Forum - das Archiv

Werte suchen mit Ausschluß von Zeichenfolgen

Bild

Betrifft: Werte suchen mit Ausschluß von Zeichenfolgen
von: Ralf-Eckhard

Geschrieben am: 30.03.2008 17:52:42

Hallo.
Ich habe ein relativ umfangreiches Straßenverzeichnis mit ca. 13.000 Einträgen. Ich möchte nun in dieser Tabelle in der Spalte A nach Strassen suchen, die die Zeichenfolge "str" bzw. "Str" enthalten. Dabei sollen aber die Strassen ausgeschlossen werden, die die Zeichenfolge "str." bzw. "Str." (also jeweils mit "Punkt") oder "straße" bzw. "Straße" enthalten.
Am genialsten wäre es wenn die Treffer in einem separaten Blatt mit Angabe der Zeilennummer gelistet würden.
Kann mir hierbei jemand helfen?
Danke im voraus,
Ralf-Eckhard

Bild

Betrifft: AW: Werte suchen mit Ausschluß von Zeichenfolgen
von: Daniel

Geschrieben am: 30.03.2008 18:24:05
Hi
verwende doch in einer Hilfsspalte diese Formel (in Zeile 1 eintragen und nach unten kopieren), die Grosschreibung wird von der ZählenWenn-Funktion ignoriert und muss daher nicht berücksichtigt werden:
=ZÄHLENWENN(A1;"*str*")-ZÄHLENWENN(A1;"*str.*")-ZÄHLENWENN(A1;"*strasse*")-ZÄHLENWENN(A1;"*straße*")
alle bezeichungen in Spalte A, die deinen Anforderungen entsprechen, haben als Ergebnis 1, alle anderen 0 oder kleiner.
Du kannst dann diese Zeilen per Autofilter selektieren oder bei bedarf mit der Bedingten Formatierung Farblich hervorheben.
Gruß, Daniel

Bild

Betrifft: enden die Straßennamen immer
von: WF

Geschrieben am: 30.03.2008 19:23:58
mit str dann in A1 der Tabelle2 die Arrayformel:
{=KKLEINSTE(WENN(RECHTS(Tabelle1!A$1:A$19;3)="str";ZEILE($A$1:$A$6));ZEILE(Tabelle1!A1))}
und in B1:
=INDEX(Tabelle1!A:A;A1)
beide runterkopieren
ARRAY-Formel {=geschweifte Klammern} nicht eingeben;
Abschluß der Formel mit gleichzeitig Strg / Shift / Enter; - das erzeugt sie.
Salut WF

 Bild
Excel-Beispiele zum Thema "Werte suchen mit Ausschluß von Zeichenfolgen"
Zellinhalt suchen und Zelle auswählen Suchbegriff über mehrere Tabellenblätter suchen.
Suchen und weitersuchen Zahl +/- 1 suchen
Ein Zeichen in einer Formel suchen Datum suchen und Wert eintragen
Wert in Tabelle suchen und in UserForm ausgeben Letzte Zelle mit Inhalt suchen
Textdatei nach Begriff durchsuchen und Fundzeile importieren Wert in Array suchen, ohne jedes Datenfeld abzufragen