Microsoft Excel

Herbers Excel/VBA-Archiv

Suchen von Zeichenfolgen

Betrifft: Suchen von Zeichenfolgen von: Ralf
Geschrieben am: 01.08.2006 15:45:21

Hallo Excel - Experten,

ich möchte in einer Spalte A ( mit 4000 6-stelligen Zahlen (Pivottabelle ))
diejenigen herausfiltern, die eine bestimmte Ziffernkombination haben.
z.B. ich geben in AH7 5226 ein und dann hätte ich gerne, das mir Excel
alle vorkommenden Kombinationen aus Spalte A d.h. z.B. 522601
522602, 522603, 522604... auflistet, oder wenn ich 26 eingebe, dass
mir Excel dann alle Zahlen in denen die 26 vorkommt auflistet, egal
ob sie hinten vorne oder in der Mitte steht.
Geht soetwas überhaupt ???
Ich habe es mal mit folgender Formel versucht, sie funktioniert auch
relativ gut, aber irgendwie ist da der Wurm drin, denn sie hört aus
(mir) unerklärlichen Gründen plötzlich auf :-( oder listet mir alle 5er auf,wenn ich z.B. eine 5 eingebe :-(


=WENN(ZEILE()>SUMME(ISTZAHL(SUCHEN(AH$7;A$1:A$10000))*1);"";INDEX(A:A;
KKLEINSTE(WENN(ISTZAHL(SUCHEN(AH$7;A$1:A$10000));ZEILE($1:$10000));ZEILE(A1))))

Hat jemand von Euch Experten hierzu eine Idee ???
Wäre für jeden Tipp dankbar!
Gruß
Ralf

  


Betrifft: AW: Suchen von Zeichenfolgen von: Heide_Tr
Geschrieben am: 01.08.2006 16:38:02

hallo Ralf,

Du könntest in Deine Daten eine Hilfsspalte einfügen, die Du mit 0 oder 1 belegst, je nach dem, ob die Zahl den Teilstring enthält oder nicht (hier wird 34 gesucht):

=WENN(ISTFEHLER(FINDEN("34";TEXT(A1;"00000")));0;1)

Anschließend ziehst Du diese Hilfsspalte in der Pivot-Tabelle in den Seitenbereich und definierst über ihre Feldeigenschaften: ausblenden bei 0.

Problem ist, dass Du bei jedem neuen Suchstring die Formel ändern musst. Daher ist es sicherlich geschickter, den Suchstring in eine Hilfszelle (z.B. H1) einzugeben (Text!) und dann in der Formel darauf zu verweisen:

=WENN(ISTFEHLER(FINDEN($H$1;TEXT(A2;"00000")));0;1)

viele Grüße. Heide


  


Betrifft: AW: Suchen von Zeichenfolgen von: Ralf
Geschrieben am: 01.08.2006 16:54:02

Hallo Heide,
vielen Dank für Deine Mühe.
Es ist ein guter Tipp und eine echte
Alternative. Vielen Dank dafür.
Für heute ist aber Schluß, ich werde
es morgen früh ausprobieren :-)
:-) Gruß
Ralf


  


Betrifft: AW: Suchen von Zeichenfolgen von: HermannZ
Geschrieben am: 01.08.2006 17:15:58

hallo Ralf;

du warst schon mit deiner Formel auf dem richtigen Weg, ein beispiel;

 
 ABC
71   
72Tabelleges. Zahlen-KombiErgebniss
7352260126522601
74522602 522602
75522603 522603
76522604 522604
77522701 520261
78522702 520262
79522703 520263
80522704  
81520261  
82520262  
83520263  
84  Formel nach
85  untenkopieren
Formeln der Tabelle
C73 : {=WENN(SUMME(WENN(ISTZAHL(FINDEN($B$73;$A$73:$A$83));1))<ZEILE(A1);"";INDEX(A:A;KKLEINSTE(WENN(ISTZAHL(FINDEN($B$73;$A$73:$A$83));ZEILE($73:$83));ZEILE(A1));1))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hermann


  


Betrifft: Riesengroßen DANK Hermann :-) von: Ralf
Geschrieben am: 02.08.2006 08:52:35

Hallo Hermann,
ich habe es gerade ausprobiert, und
wie man so schön sagt, es F U N Z T ganz super

Vielen vielen Dank dafür
Gruß
Ralf


 

Beiträge aus den Excel-Beispielen zum Thema "Suchen von Zeichenfolgen"